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1 Introduction

1.1 Introducing ES3D

ES3D (Electrostatic Field Solver for Multilayer Circuits), Version 1.0, is a computer program used for the 3D 
electrostatic analysis of multilayer printed circuit boards (PCBs), low-temperature cofired-ceramic (LTCC) circuits, 
integrated circuits (ICs), microelectromechanical systems (MEMS), and similar structures used in radio-frequency 
(RF) and microwave (MW) devices, fast digital circuits and interconnects, and other hardware. An example of an 
analyzed structure is shown in Figure 1.1.

Figure 1.1 Structure analyzed by ES3D. 

The input to ES3D is through a built-in graphics editor or an interface to AutoCAD® and similar programs that can 
handle the drawing interchange file (DXF) format.

ES3D also has the capability to analyze arbitrarily shaped conductors and dielectric bodies that are externally 
defined by the user.

The numerical technique implemented in the program is based on the Method of Moments [1]. The program output 
consists of files with the following data:

• Self and mutual capacitances (matrix form),

• A circuit description of the capacitances (in Touchstone®-compatible format),

• Tabulated admittance parameters as a function of frequency (in Touchstone®-compatible format).



1.2 System Requirements for ES3D

The following sections list the hardware and software required to install and run ES3D.

1.2.1 Hardware Requirements

The minimum hardware requirements include:

• IBM® or compatible computer with Pentium® or other compatible processor,

• Hard disk with 50 MB of available space,

• 256 MB of available RAM.

1.2.2 Software Requirements

ES3D requires a Windows® 98 or later operating system, including ME, 2000, and XP.

1.2.3 Additional Requirements

Depending on the program distribution, additional hardware and software are needed, as follows:

• To download and install ES3D from the Artech House Web site (http://www.artechhouse.com), an Internet 
connection is required.

• To install ES3D from a CD, a CD-read drive is required. 

ES3D can be installed only on individual computers, not on a network.

See also: Installing ES3D.



1.3 Installing ES3D

ES3D is distributed on one standard CD, or it can be downloaded from the Artech House Web site 
(http://www.artechhouse.com).

1.3.1 Installing from a CD

To install ES3D from a CD, perform the following steps:

• Insert the installation CD into a drive. 

• Wait a few seconds for the installation program to start automatically. 

o If the installation program does not start automatically, perform the following steps:

� Open the Windows Start menu by clicking the Start button on the Windows taskbar.

� Select the Run option. The Run dialog box opens.

� Type the letter of the CD drive and “:\Setup”. For example, if the CD is in drive D:, type 
D:\Setup, as shown below.

� Click the OK button.

• While the installation program is loading, the Setup preparation dialog box is opened, as shown below.

• Shortly afterwards, the ES3D Setup window opens with the Welcome dialog box, as shown below.



• Read carefully and follow the instructions given by the installation program.

• Click the Next button to continue or the Cancel button to terminate the installation. The installation 
program opens the Choose Destination Location dialog box, where you can define the drive and directory 
in which ES3D will be installed, as shown below.



• The installation program suggests installing ES3D in the directory C:\Program Files\Artech\ES3D on the 
hard disk C:. Most files from the distribution CD will be copied to this directory. Examples of input data 
for ES3D will be copied to the directory C:\Program Files\Artech\ES3D\Examples. You can accept the 
name C:\Program Files\Artech\ES3D or change the directory name or drive by clicking the Browse button. 
If the specified directory does not exist, the installation program will automatically create it.

• Click the Next button to continue or the Cancel button to terminate the installation. Following this step, 
files are copied from the installation CD to their destinations on the hard disk. During this task, the ES3D 
Setup dialog box remains open, displaying the status of the copying, as shown below.



• After copying all requested files, the installation program announces that the installation is complete, as 
shown below.

• Click the OK button to terminate installation. The ES3D folder opens, as shown below.



• You can run ES3D by clicking its icon . You can create a shortcut to the program using the standard 
Windows procedure. 

• A program group is automatically created on the Programs menu. 

• Remove the distribution CD from the drive and store it in a safe place. 

ES3D is now ready to run in the Windows environment.

1.3.2 Downloading and Installing from the Artech House Web Site

• Follow the instructions given by Artech House for accessing and downloading the ES3D installation file. 

• Save the downloaded self-extracting file ES3D_distribution.exe to a directory on the hard disk. 

• Locate the file ES3D_distribution.exe using Windows Explorer. Execute the file by double-clicking it. The 
file is unpacked in the same directory where the downloaded file is saved. 

• Run program Setup.exe. 

• The remainder of the installation procedure is the same as when installing ES3D from a CD.

See also: Running ES3D; Removing ES3D.



1.4 Removing ES3D

You can uninstall ES3D at any time by clicking the Uninstall ES3D icon in the ES3D folder. 

Alternatively, use the standard Windows procedure as follows:

• From the Start menu, choose Settings and then Control Panel.

• In the Control Panel, choose Add/Remove Programs.

• Select ES3D, click the Remove button, and click Yes if you are sure you want to remove ES3D.

• Restart your computer.

• Follow further instructions given by Windows, if any.

See also: Installing ES3D.



1.5 Running ES3D

After installing ES3D, you can run it in the following way:

• Open the Start menu and select the Programs option. The Programs menu opens.

• In the Programs menu, select the ES3D program group. The ES3D Group menu opens.

• In the ES3D Group menu, click the ES3D icon .

Alternatively, perform the following steps:

• Use Windows Explorer to locate the executable file ES3D.exe. If nothing was modified in the installation 
procedure, ES3D.exe resides in the directory C:\Program Files\Artech\ES3D.

• Double-click the ES3D icon  or double-click the ES3D.exe name.

If you plan to use ES3D frequently, you may create a shortcut on the desktop.

To terminate ES3D, perform the following steps:

• In the ES3D main window, select the File menu.

• In the File menu, select the Exit option.

Alternatively, in the ES3D main window, press Alt+F4.

See also: Installing ES3D; Using ES3D Help.



1.6 Using ES3D Help

The ES3D Help uses standard Microsoft Windows® Help services. Help is available in ES3D by pressing the F1 
key or by using the Help menu. 

Help for most ES3D windows and dialog boxes is located in the file ES3D.hlp. For the 3D Viewer, Help is also 
located in the file ES3D_View.hlp. Both files reside in the ES3D root directory. 

The Help files can also be opened directly from Windows Explorer. Locate a file using Windows Explorer, and 
double-click the filename or its icon. The file ES3D.hlp is also accessible by opening the Windows Start menu, 
selecting the Programs option, opening the ES3D program group, and clicking the ES3D Help icon.

Upon starting the ES3D Help, the Help window opens and the ES3D Help Contents is displayed, as shown below.

Click a section title to open the corresponding topic. For example, clicking 1.1 Introducing ES3D displays the 
following window:



Available menus and options in the Help window are as follows:

• File menu

o Openopens a new Help file (with the default name extension hlp).

o Print Topicprints the currently opened topic.

o Exitcloses Help; same as pressing the Escape key or using the Alt+F4 key combination.

• Edit menu

o Copycopies the selected text; same as using Ctrl+C. A text selection can be made by dragging 
over it with the mouse.

o Annotateannotates the currently opened topic.

• Bookmark menu

o Definedefines a bookmark.

o List of bookmarksjumps to an already defined bookmark.

• Options menu

o Keep Help on Topallows a choice among always keeping the Help window on top of other 
windows, not keeping it on top  (turning it off), or using the default handling. The default 
handling in the ES3D Help does not keep the Help window on top.

o Display History Windowshows a list of all windows displayed previously within the current 
session. From that list, you can jump directly to a previously displayed window.

o Fontselects the font size (small, normal, or large).

o Use System Colorsuses colors for the Help window as defined by the operating system.

• Help menu



o Versiondisplays copyright information about Microsoft Windows Help and about ES3D.

The following buttons are available in the toolbar:

• Contentsopens Help Contents.

• Indexopens the Index tab in the Help dialog box. Select a keyword to open a topic that contains 
explanations on that keyword or click the Cancel button to return to the Help window.

• Findopens the Find tab in the Help dialog box. Search the entire ES3D Help for a word or a phrase. 
Click the Options button to customize the search or click the Cancel button to return to the Help window.

• Backreturns to the previously opened topic.

• Printprints the currently opened topic.

• Optionsduplicates the Annotate, Copy, Print Topic, Font, Keep Help on Top, and Use System Color 
options from the menus.

• <<<<<<<<opens the previous topic in the sequence defined in the ES3D Help.

• >>>>>>>>opens the following topic in the sequence defined in the ES3D Help.

See also: Running ES3D; Installing ES3D.



1.7 Copyright

The software and the accompanying documentation are copyright © 2007 by Artech House, Inc. No part of this 
software and documentation may be reproduced, stored in a retrieval system, or transmitted, in any form or by any 
means, electronic, mechanical, recording, or otherwise, without prior written permission from Artech House.

For referencing ES3D, the full title of this software is:

Marija M. Nikolić, Antonije R. Djordjević, and Miloš M. Nikolić

ES3D: Electrostatic Field Solver for Multilayer Circuits

Version 1.0

Norwood, MA: Artech House, 2007

See also: About the Authors; Disclaimer of Warranty.



1.8 Disclaimer of Warranty

The technical descriptions, procedures, and computer programs have been developed with the greatest of care, and 
they have been useful to the authors in a broad range of applications; however, they are provided as is, without 
warranty of any kind. Artech House, Inc., and the authors and editors of the software titled ES3D: Electrostatic 
Field Solver for Multilayer Circuits, Version 1.0, make no warranties, expressed or implied, that the equations, 
programs, and procedures in the software are free of error, consistent with any particular standard of 
merchantability, or will meet your requirements for any particular application. They should not be relied upon for 
solving a problem whose incorrect solution could result in injury to a person or loss of property. Any use of the 
programs or procedures in such a manner is at the user’s own risk. The editors, authors, and publisher disclaim all 
liability for direct, incidental, or consequent damages resulting from use of the programs or procedures in this 
software. 

See also: Copyright.



2 Using ES3D

2.1 Getting Started

We shall run an example supplied with ES3D to take a quick tour through ES3D. 

The example deals with the evaluation of capacitances of pads for soldering surface-mount devices (SMD) on 
printed circuit boards (PCBs). In particular, we consider pads for mounting size 0805 components on the FR-4 
substrate (Figure 2.1). Pads are rectangular patches in the top layer. The dimensions of a pad are 60 mils by 50 mils. 
The separation between the pads is 30 mils. The substrate thickness is 62 mils and the relative permittivity is 4.6. 
The bottom layer of the PCB is a solid ground plane.

Figure 2.1 Pads for 0805 components (top layer). All dimensions are in mils.

Run ES3D. The ES3D main window appears as shown below.

• During the quick tour, you may prefer to keep the Help window on top of all other windows. To do so, 
open the Options menu in the Help window, select the option Keep Help on Top, and check the On Top 
option. You may later check the Default option to prevent the Help window from always appearing on top 
of other windows.

• In the ES3D main window, open the File menu and select the Open option. Locate the ES3D root 
directory. The root directory is created during program installation and the default is C:\Program 
Files\Artech\ES3D. Locate the subdirectory Examples. In this subdirectory, locate the file 0805pads.e3d, 
as shown below. Open this file by double-clicking its name. 



• The ES3D main window now looks as shown below. It displays a top view of the PCB, with the two pads 
(rose) and the PCB ground plane (blue). 

• To prepare the pads for the numerical analysis (using the Method of Moments [1]), the structure must be 
segmented first. In other words, all conductor and dielectric surfaces must be divided into small patches. 
Open the Compute menu and select the Segment option. After a short time, the program displays a message 
about the number of unknowns (patches). Click the OK button to continue.

• Display the segmented structure by opening the View menu and selecting the 3D View option. The ES3D 
View window opens as shown below.



• Close the ES3D View window by pressing Escape. This brings you back to the ES3D main window.

• To start the numerical analysis of the pads, open the Compute menu and select the option Run. A progress 
bar shows the status of computations, as shown below. 

• After the computations are done, a dialog box appears, as shown below. Click the OK button to continue.

• We are ready to examine the results. Open the List menu and select the option Ckt. Notepad opens the 
output-data file 0805pads.ckt, which looks as shown below.

CAP 1 0 c= 1.636835e-001

CAP 1 2 c= 2.032912e-002

CAP 2 0 c= 1.637206e-001

The file is a description of a circuit that represents the pads in Figure 2.1. The circuit consists of three 
capacitors, shown in Figure 2.2, whose capacitances are in picofarads (pF).



Figure 2.2 Equivalent network of partial capacitances for the pads shown in Figure 2.1.

The first capacitor (c10=0.164 pF) is connected between the left pad (pad 1) and the ground. This capacitor 
represents the self capacitance of the first pad. 

The second capacitor (c12=0.020 pF) is connected between the left pad (pad 1) and the right pad (pad 2). 
This capacitor represents the mutual capacitance between the pads. 

The third capacitor (c20=0.164 pF) is connected between the right pad (pad 2) and the ground. This 
capacitor represents the self capacitance of the second pad.

• Close Notepad by opening its File menu and selecting the Exit option.

• Close ES3D by opening its File menu and selecting the Exit option. This concludes the quick tour.

See also: Running ES3D; Tutorial; Examples.



2.2 ES3D Components

ES3D consists of the main program ES3D.exe, which performs the majority of user-interface functions, and several 
other executable files and dynamic-link libraries.

The user-interface functions are accessible in the ES3D main window, which typically looks as shown below. 

The ES3D main window has several menus, toolbars, and areas. Several dialog boxes and windows are invoked 
from the ES3D main window, as necessary.

• The Drawing area occupies the major part of the ES3D main window. Several projects can be 
simultaneously opened by ES3D. Each project has its Drawing window, which is located in the Drawing 
area. In the example shown above, only one project is opened, and its Drawing window is maximized.

• Menus in the ES3D main window perform the following functions:

o Filehandles input-data files. It starts a new project and opens, closes, and saves files. It also 
handles importing and exporting of DXF files. The File menu contains a list of the most recently 
opened projects, and it has an option to terminate ES3D.

o Edithandles the current drawing, including undo/redo actions and copy/paste operations.

o Viewdefines the layout of the ES3D main window and handles zooming and panning of the 
drawing. The View menu also defines the grid and the draw mode setting, and it invokes the 
ES3D View window.



o Arrangehandles polygon front/back ordering and subtracting.

o Drawinitiates drawing rectangles, polygons, and vias.

o Projectoffers options for creating new layers and for numerical definition of polylines and vias. 
It also handles the footprint and the sidewall metallizations, and it provides access to the Project 
Settings dialog box.

o Computeinitiates the operations necessary to analyze the structure, including checking, 
segmenting, and numerical analysis.

o Listinvokes Notepad to open the three output files that contain results of the numerical analysis.

o Windowarranges the Drawing windows and enables switching among them.

o Helpopens the ES3D Help window and displays copyright data.

• Toolbars duplicate some functions from the menus and provide additional tools and information. The 
following toolbars are available in the ES3D main window:

o Standard manages input-data files, copy/paste 
operations, and zooming.

o Tools provides drawing tools for selection and drag-and-drop 
operations, drawing polygons, rectangles, and vias, and panning and zooming. 

o Info displays information about 
the current position of the drawing cursor and manages the active layer.

o Compute provides checking, segmenting, 3D viewing, running, 
and listing functions.

• Project barcontains summary information about layers, polygons, and vias. It can also be used to access 
properties of layers, polygons, and vias and to change the active layer.

• Status bardisplays information about the polygon, via, or button that is currently under the cursor. It 
also shows the dimensions of the footprint.

Several dialog boxes and other windows can be opened from the ES3D main window. The major dialog boxes and 
windows are listed below.

• Settings dialog boxmanages project settings for units, frequencies, segmentation, grid and footprint, and 
listing output data. Select the Settings option in the Project menu to open the box. The Settings dialog box 
looks as shown below.



• Layers windowcontains information about layers and modifies layer properties. The Layers window is 
opened if the Layers option in the View menu is checked. The Layers window looks as shown below.

• Layer Properties dialog boxdefines data for a layer. The box can be opened by double-clicking the 
layer name in the Layers window. The Layer Properties dialog box looks as shown below.

The box is the same as the New Layer dialog box.

• Polygon dialog boxdefines data for a polygon. The box can be opened by double-clicking the polygon 
in the Drawing window. The Polygon dialog box looks as shown below.



• Via dialog boxdefines data for a via. The box can be opened by double-clicking the via in the Drawing 
window. The Via dialog box looks as shown below.

• ES3D View windowprovides a 3D view of the segmented structure. The window can be opened by 
selecting the 3D View option in the View menu. The ES3D View window looks as shown below.



The ES3D View window has functions for rotating, zooming, panning, and clipping the displayed structure.

See also: Reference Manual.



2.3 ES3D Input

2.3.1 Analyzed Structure

ES3D is designed for electrostatic analysis of 3D multilayer structures, such as printed circuit boards (PCBs), 
low-temperature cofired-ceramic (LTCC) devices, integrated circuits (ICs), and similar structures.

In the general case, the analyzed structure consists of several dielectric layers, as shown in Figure 2.3. The 
permittivities of the layers may be equal or they may be different.

Figure 2.3 Structure analyzed by ES3D.

The overall shape of the structure is a parallelepiped. The sidewalls of the structure can be individually metallized. 
The surrounding medium is a vacuum.

The metallization layers coincide with the interfaces between any two adjacent dielectric layers (including the 
interfaces between the dielectrics and a vacuum). The metallization layers are labeled 0, 1, 2, and so on. Layer 0 is 
on the bottom of the first dielectric (at z=0), Layer 1 is at the interface between the first dielectric and the second 
dielectric, and so on. In each metallization layer, there are printed polygonal conducting patterns (metallizations). 
(A layer may be void of metallization.) Polygons in adjacent or nonadjacent layers can be interconnected by vias.

One or several polygons constitute one electrostatic conductor. Such polygons are assumed to be galvanically 
interconnected (i.e., to be on the same electrostatic potential). Conductors are indexed 0, 1, 2, and so on.

In the basic electrostatic-field representation, all conductors are “hot,” and the reference point is at infinity. In the 
circuit representation, however, Conductor 0 is the reference conductor (ground). All other conductors (Conductor 
1, Conductor 2, and so on) are hot (signal) conductors. ES3D gives results for both representations.

2.3.2 Data Input

Data that define the analyzed structure consists of the following items:

• Footprint dimensions, Length and Width. The footprint is a rectangle, located in the Oxy plane of the 
Cartesian coordinate system, as in Figure 2.3. The coordinates are within the limits 0≤x≤Length and 0≤y≤
Width. The coordinate origin is in the lower-left corner of the drawing in the ES3D Drawing window. 
Footprint dimensions are entered numerically when a new project is started, and they can be adjusted later 
by using the Footprint option in the Project menu. 

• Data for sidewalls. Each of the four sidewalls of the structure can be individually metallized by using the 
Metallization option in the Project menu. The metallization is assumed to be the reference conductor 



(ground).

• Data for layers. Each metallization layer is defined by its name, relative permittivity of the dielectric 
material that is below the layer, z-coordinate of the upper surface (z>0), and color. An exception is the 
lowest layer (whose default name is Layer 0). This layer is the bottom face of the structure. For this layer, z
=0, and the relative permittivity is 1, which is the relative permittivity of the surrounding medium (a 
vacuum). This data for the lowest layer cannot be modified. 

A new layer is added by using the New Layer option in the Project menu. A layer can be made visible or 
invisible, locked or unlocked. Layer properties of an existing layer can be modified by right-clicking the 
layer name in the Project bar and selecting the Properties option or by working from the Layers window. 
(The Project bar and the Layers window can be displayed or hidden by using the corresponding options in 
the View menu.) A layer can be deleted by right-clicking the layer name and selecting the Delete option. 

• Data for metallization patterns (polygons). Each polygon is planar. It is located on the upper surface of the 
corresponding dielectric layer. A polygon is bounded by a polygonal line (polyline). The polyline is 
defined by a set of nodes (at least three nonaligned nodes). The nodes are interconnected by straight lines 
(edges). A polyline can be drawn opened or closed, but in the analysis, it is always treated as closed. To 
define a polygon, make the corresponding layer active by clicking it in the Layers window. Draw the 

polyline using the Polyline Tool  in the Tools toolbar. To close the polyline, press the C key on the 

keyboard. A rectangle can be drawn using the Rectangle Tool . A new polygon can also be defined by 
selecting the New Polygon option in the Project menu. The Polygon dialog box opens, in which node 
coordinates can be entered manually. Polygon edges must not intersect each other. The z-coordinate of the 
polygon automatically matches the z-coordinate of the layer in which the polygon is drawn. The Index 
entry is the index of the electrostatic conductor, a part of which is the polygon.

• Data for vias. A via is defined by clicking the Via Tool button  or the New Via option in the Project 
menu and entering the coordinates (x,y) of its center, its radius, and the two layers (top and bottom) that are 
interconnected by the via. A via is assumed to galvanically interconnect all polygons that are penetrated by 
it. All of the interconnected polygons must belong to the same conductor. A via must intersect at least one 
polygon. A via can be hollow or solid.

2.3.3 Data Importing

Data for polylines and vias can be input from AutoCAD® or a similar program. In AutoCAD®, layers should be 
defined and 2D polylines plotted in each layer, in the same way as in ES3D. Vias should be plotted as circles in the 
layer “VIA”. The footprint outline should be a rectangle (a 2D polyline) in the layer “FRAME” (x≥0 and y≥0). All 
patterns must be within the footprint outline, and two edges of the footprint outline should be at x=0 and y=0.

The data should be saved in a DXF file (AutoCAD® version 2000) and then imported into ES3D using the Import 
option in the File menu. Upon import, the relative permittivities and the z-coordinates for layers should be defined 
in the same way as when layers are defined in the ES3D editor. The unit in AutoCAD® represents one user's unit 
that is defined in ES3D.

2.3.4 Data Saving

All input data required by ES3D can be saved in a file using the Save or Save As options in the File menu. The 
input-data file can be loaded later using the Open option in the File menu.

2.3.5 Data Exporting

The data from the ES3D graphics editor can be exported to a DXF file (AutoCAD® version 2000), using the Export 
option in the File menu. In this export, polygons are converted to lines that are elevated to take into account the 



actual z-coordinates. Each via is converted to two circles located at the corresponding elevations and interconnected 
by vertical lines that represent the walls of the via.

2.3.6 Units

Lengths are entered in the unit selected by the user (millimeter, meter, inch, or mil). The unit can be defined using 
the Settings option in the Project menu (Units tab).

2.3.7 Frequency Range

The self and mutual capacitances for the analyzed structure form a multiport network whose admittance (y) 
parameters are tabulated at equispaced frequencies. These frequencies are defined in the Settings dialog box, by the 
start frequency, stop frequency, and number of frequency steps. The frequencies are in the unit selected by using the 
Settings option in the Project menu (Units tab).

See also: Reference Manual.



2.4 Analysis Procedure

2.4.1 Data Saving

The structure defined in the ES3D graphics editor is saved by clicking the Save button  in the Standard toolbar 
or by selecting the Save or Save As options in the File menu. The structure should be saved before proceeding to the 
following steps. The extension of the saved file is e3d. The filename becomes the name of the current project.

2.4.2 Checking

The defined structure can be checked using the Check button  in the Compute toolbar or by selecting the Check 
option in the Compute menu. If an error is detected, it is reported in the Error dialog box.

2.4.3 Segmenting

Before the numerical analysis is performed, all metallic surfaces (polygons, vias, and sidewalls) and 
dielectric-to-dielectric interfaces must be meshed (segmented) into patches (usually rectangular and triangular). A 

self-adaptive segmentation is performed by clicking the Segment button  in the Compute toolbar or by selecting 
the Segment option in the Compute menu.

The parameters for the segmentation scheme are defined in the Segmentation tab of the Settings dialog box 
(accessible from the Project menu). 

The Resolution parameter defines the size of the smallest patch. The smallest patch size diminishes with increasing 
Resolution. The recommended value of the Resolution parameter is 1.

The Refine parameter defines the rate at which the patch size diminishes going toward an edge or wedge of the 
analyzed structure. Increasing Refinement increases the steepness of the patching scheme. The recommended value 
of the Refine parameter is 1. 

The Number of VIA segments parameter defines the number of vertices of a polygon that is used to approximate a 
circular via. The recommended number is in the range 4−6. The polygon is midway between the polygon that is 
inscribed into the via circle and the polygon that is circumscribed around the via circle.

2.4.4 3D Viewing

A segmented structure can be displayed as a 3D view by clicking the 3D View button  in the Compute toolbar or 
by selecting the 3D View option in the View menu. In the ES3D View window, the displayed structure can be 
rotated around three orthogonal axes, zoomed in and out, and panned. The segmented structure can also be clipped 
from the top or bottom to display the interior.

2.4.5 Analysis

The numerical analysis of the structure is initiated by clicking the Run button  in the Compute toolbar or by 
selecting the Run option in the Compute menu. Depending on the number of patches (unknowns), the analysis can 
take from a fraction of a second up to several minutes.

Segmenting the structure, running the analysis, and displaying results can be performed by using a single command, 

AutoRun, available by clicking the AutoRun button  in the Compute toolbar or by selecting the AutoRun option 
in the Compute menu.



See also: Reference Manual.



2.5 ES3D Output

The results of ES3D are as follows:

• The matrix [B] of electrostatic-induction coefficients and the matrix [C] of partial capacitances. Hereby, 
the ground conductor (Conductor 0) is treated as a hot conductor, and the reference point (the 
zero-potential point) is at infinity. The first row and column in each matrix correspond to Conductor 0, the 
second row and column correspond to Conductor 1, and so on. The output also contains the date and time 
when the analysis ended and the duration of the computation. These results are displayed upon selecting 
the C Parameters option in the List menu, and they are automatically saved in an ASCII data file with the 
extension dat.

• A description of the network formed by the partial capacitances. The description is in 
Touchstone®-compatible format. The capacitances are in pF. The potential of Conductor 0 is assumed to 
be zero (i.e., this conductor is short-circuited to the reference point at infinity). Conductor 0 corresponds to 
node 0, Conductor 1 corresponds to node 1, and so on. These results are displayed upon selecting the Ckt 
option in the List menu, and they are automatically saved in an ASCII data file with the extension ckt.

• Tabulated admittance (y) parameters of the network formed by the partial capacitances. This is the same 
network as described in the ckt file. The unit for the frequency is selected in the Settings dialog box, the 
format is the real and imaginary part, and the admittance parameters are in siemens (S). These results are 
displayed upon selecting the Y Parameters option in the List menu, and they are automatically saved in an 
ASCII data file with the extension y*p, where the asterisk stands for the number of ports.

The name of all saved output files is the same as the name of the project. The output files are saved in the same 
directory as the input-data file.

The List button  in the Compute toolbar opens one, two, or all three output files, depending on the settings in 
the Output tab of the Settings dialog box (accessible from the Project menu).

See also: Reference Manual.



2.6 Tutorial

2.6.1 Example

In this tutorial, we shall analyze the structure shown in Figure 2.4. The structure consists of two dielectric layers, 
ground metallization all over the bottom, and two rectangular patches. The sidewalls are void of metallization.

Figure 2.4 Tutorial example. All dimensions are in millimeters. Not drawn to scale.

2.6.2 Starting ES3D

• Start ES3D using the standard Windows procedure. The ES3D main window opens.

• In the Project menu, select the Settings option.

o In the Units tab, verify that the selected unit for coordinates is millimeter, as shown below. 

o In the Editor tab, enter 1 mm for grid spacing and verify that the checkbox for the default 
footprint is not checked, as shown below. Click OK to continue.



• In the File menu, select the New option to start a new project. The New Project dialog box appears as 
shown below.

In the New Project dialog box, define the Length and Width of the footprint to be 13 mm and 12 mm, 
respectively. Click OK to close the dialog box.

• The ES3D main window appears as shown below. 



The Drawing window shows the top view of the layout. The horizontal axis is the x-axis, the vertical axis is 
the y-axis, and the coordinate origin is at the lower-left corner. The Drawing window shown above displays 
the footprint of the structure. 

A grid is superimposed to facilitate drawing (by snapping to this grid). If the grid is not displayed, check 
the Show Grid option in the View menu. Also, verify in the View menu that the Snap to Grid option is 
checked. 

2.6.3 Defining Input Data

• Metallization patterns are drawn in layers. To manage the layers, the Layers window can be used. This 
window appears detached from the ES3D main window. If the Layers window is not already displayed, 
check the Layers option in the View menu. The Layers window should look as shown below. 

• Layer 0 is the default layer at the bottom of the structure (z=0). This layer is active now. We want to 

metallize this layer and make it be the ground conductor. Using the Polyline Tool  or the Rectangle 

Tool , draw a rectangle all over the gridded region (i.e., over the whole footprint). The Rectangle tool 
is easier in this case. Select this tool by clicking it in the Tools toolbar. Position the mouse cursor at the 
coordinate origin (lower-left corner of the footprint) and left-click the mouse to define one point of the 
rectangle. Expand the rectangle by dragging the other point (node) to the upper-right corner of the footprint 
and release the mouse button. 



The ES3D main window looks as shown below.

The polygon that we have just drawn (Polygon 0) is listed in the Project bar as an object in Layer 0.

• Once drawn, the rectangle is treated as any other polygon. In the Drawing window, right-click on the 
rectangle that we have just drawn and select the Properties option. The Polygon dialog box opens as shown 
below.

The Polygon dialog box defines the index of the electrostatic conductor to which the polygon belongs. In 
the present case, this is the ground conductor (Conductor 0). The box also displays the name of the layer in 
which the polygon is drawn (Layer 0) and the corresponding layer elevation (z-coordinate). The node 
coordinates (x,y) are displayed in the table. The Polygon dialog box has a checkbox that defines if the 



polyline is open or closed. In this case, all entries are exactly as we expected. Click the OK button to close 
the Polygon dialog box and continue the tutorial.

• We need to define two more layers. According to Figure 2.4, the elevation of the upper surface of the first 
layer is z=1.5 mm and the relative permittivity of the layer is εr=4.6. The elevation of the upper surface of 
the second layer is z=3.0 mm, and the relative permittivity is εr=3.5. 

To define the first layer, open the Project menu and select the New Layer option. The New Layer dialog 
box opens, as shown below.

In the New Layer dialog box, define the relative permittivity (4.6) and the elevation of the upper surface of 
the layer (1.5 mm). The elevation must be positive and all layers must have distinct elevations. The name 
of the layer can be arbitrary. Let us accept the default name of the layer (Layer 1). 

In the New Layer dialog box, we can also define if the layer is visible in the Drawing window and if it is 
locked. Keep the selections as shown above to have the layer visible and unlocked. Close the New Layer 
dialog box.

Repeat the same procedure for the second layer (relative permittivity of 3.5, elevation of the top face of 
3 mm, name of Layer 2). Thereafter, the Layers window should look as shown below.

• Make Layer 1 active by clicking it in the Layers window. In the Drawing window, draw a rectangle in 
Layer 1. Let the lower-left node of the rectangle have coordinates (2,3), and let the coordinates of the 
diagonally opposite node be (9,8), as shown below.



As we draw, all layers and respective polygons are listed in the Project bar.

• Open the Polygon dialog box for this rectangle and define that this rectangle belongs to Conductor 1. The 
Polygon dialog box should thereafter look as shown below. 

If you do not have the same node coordinates as shown above, you may modify them by entering 
appropriate numbers in the table. Close the dialog box.

• Now, draw a rectangle in Layer 2, as shown below.



• Make this rectangle belong to Conductor 2, as shown below. 

Verify if you have the same node coordinates as above. Close the dialog box. This completes the data input.

• Save the input-data file by selecting the Save option in the File menu. Let us call this project TutorialNew. 
(The sample file Tutorial.e3d, distributed with ES3D, contains the same data as we have defined here.)

2.6.4 Computing

• After we have saved the input-data file, we proceed to the analysis of the structure shown in Figure 2.4.

• Click the Check button  in the Compute toolbar to verify the input data. It should be OK.



• Click the Segment button  in the Compute toolbar to mesh the structure. After this operation is 
completed, a message appears giving the total number of unknowns in the numerical model, as shown 
below.

• Click the 3D button  in the Compute toolbar to display the segmented structure. The ES3D View 
window opens, as shown below.

A top view of the structure is shown. The red patches correspond to the metallic rectangle in the top layer 
(Layer 2). The green patches correspond to the surfaces of the dielectrics. 

• To see the interior of the segmented structure, open the Clip menu and check the ClipUpper option. Press 
the Delete and Insert keys on the keyboard to move the clipping plane down or up, respectively. After 
clipping the top layer, the segmented structure looks as shown below, displaying the rectangle in Layer 1.

Press Escape to close the ES3D View window and return to the ES3D main window.

• Click the Run button  to start the analysis. While the analysis is running, a dialog box displays the status 



of computations, as shown below.

There are two stages of computations: filling in the matrix elements and solving the resulting system of 
linear equations. 

• After all computations have been completed, the following dialog box appears.

Click OK to continue. We are ready to see what ES3D has computed.

2.6.5 Listing Results

• The results of the analysis are automatically stored in files named TutorialNew that have the extensions dat 
(for the matrices [B] and [C]), ckt (for the circuit description), and y2p (for the tabulated y-parameters).

• Open the List menu and select the C Parameters option to see the matrices [B] and [C]. Notepad starts, 
showing data similar to the data listed below. 

Sun Aug 13 08:40:45 2006

Calculations [s]:

Matrix filling   4

Matrix inversion 0

Total time       4

Total number of unknowns 603

B matrix [F]

    2.53076e-012   -1.54752e-012   -4.53325e-013

   -1.52926e-012    2.12146e-012   -5.44346e-013

   -4.37428e-013   -5.43586e-013    1.06058e-012

C matrix [F]

    5.29915e-013    1.54752e-012    4.53325e-013

    1.52926e-012    4.78535e-014    5.44346e-013

    4.37428e-013    5.43586e-013    7.95645e-014

These are the results for the case when all electrostatic conductors (Conductors 0, 1, and 2) are treated as 



hot conductors. The first row/column in the above matrices corresponds to the ground conductor 
(Conductor 0), the second row/column to Conductor 1, and the third row/column to Conductor 2.

• Select in the List menu the Ckt option to display the circuit description of the equivalent network of 
capacitances. In this case, Conductor 0 is assumed to be grounded, and the equivalent network is shown in 
Figure 2.5 (which is the same as Figure 2.2, because in both cases we have two hot conductors).

Figure 2.5 Equivalent network of partial capacitances for the tutorial example in Figure 2.4.

The results are in Touchstone®-compatible format and they look as shown below.

CAP 1 0 c= 1.577112e+000

CAP 1 2 c= 5.439660e-001

CAP 2 0 c= 5.169926e-001

The nodes correspond to the indices of the conductors. The partial capacitances are in pF. There is a 
capacitance of 1.577 pF between node 1 and ground (node 0), a capacitance of 0.517 pF between node 2 
and ground (both are self capacitances), and a capacitance of 0.544 pF interconnecting nodes 1 and 2 
(mutual capacitance).

• We have not defined a frequency range for tabulating the admittance (y) parameters. Hence, we shall not 
examine the y-parameter file, and we are done with the output results.

2.6.6 Ending ES3D

• Terminate the tutorial by closing ES3D. To do so, open the File menu and select the Exit option.

See also: Examples; Reference Manual.



3 Theory

3.1 Introduction

ES3D is based on a numerical technique for the electrostatic analysis of arbitrarily shaped metallic bodies and 
piecewise-homogeneous dielectric bodies. 

For the analysis, the geometrical dimensions of the metallic and dielectric bodies are given by the user. All 
dimensions are finite. Hence, the analyzed structures belong to the class of 3D electrostatic problems. The relative 
permittivities of the dielectrics are also specified by the user.

The primary objective of the analysis is to evaluate the electrostatic-induction coefficients of the structure. From 
these coefficients, the self and mutual partial capacitances are calculated. The partial capacitances define the 
equivalent circuit for the analyzed structure.

The numerical analysis is based on the Method of Moments [1]. Starting from the boundary conditions, a set of 
integral equations is formulated for the free and bound surface charges. These equations are solved using a 
piecewise-constant approximation for the charges and the point-matching technique. Thereby, an adaptive meshing 
technique is used to preprocess the geometry data defined by the user.

Although the user interface in ES3D is specialized for layered geometries, the numerical technique implemented in 
the program can handle arbitrarily shaped 3D bodies. ES3D has a gateway for accepting input data for arbitrary 
structures defined by the user.



3.2 Capacitances

We consider a system of conducting bodies situated in a linear isotropic dielectric medium. The dielectric medium 
may be homogeneous or inhomogeneous. The reference point for the electrostatic potential (the zero-potential 
point) is at infinity. 

The charges of the conducting bodies and their potentials are related by linear equations. We reveal these relations, 
starting from the simplest case of one isolated body, continuing with a system of two bodies, and finally 
generalizing the relations to an arbitrary number of conducting bodies.

3.2.1 Single Conducting Body

Consider an isolated conducting body (Figure 3.1). Let the charge of the body be Q. (There are no other free 
charges in the system.) The charge Q is distributed over the surface of the body. In the vicinity of the body, there 
exists an electric field due to this charge. The electric-field vector is E.

Figure 3.1 Single charged conducting body. For simplicity, dielectric bodies are not shown.

The electrostatic potential of the body, with respect to the reference point at infinity, is given by the integral
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where M is an arbitrary point on the surface of the conducting body (the body is equipotential) and R is a point at 
infinity. At any point of the system, vector E is linearly proportional to Q, which follows from the linearity of the 
medium. Hence, the potential is also linearly proportional to Q. Consequently, the ratio

VQC =)2.3(

is a constant quantity. This ratio is referred to as the capacitance of the isolated body. The unit for the capacitance is 
farad (F).

In circuit theory, the equivalent scheme for the system shown in Figure 3.1 consists of a capacitor connected 
between the conducting body and the reference point at infinity. The capacitance of this capacitor is given by (3.2).

As an example, the capacitance of an isolated sphere located in a vacuum is C=4πε0R, where R is the radius of the 
sphere and 

F/m108542.8)3.3( 12
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is the permittivity of a vacuum. 

The capacitance (C) of a conducting body, located in a homogeneous dielectric whose relative permittivity is εr, is 
bounded by 4πεRin≤C≤4πεRout, where Rin is the radius of the sphere inscribed into the body, Rout is the radius of the 



sphere circumscribed around the body, and ε=εrε0 is the permittivity of the dielectric.

3.2.2 Capacitor

A capacitor is formed by two conducting bodies (electrodes) carrying exactly opposite charges, Q and −Q (Figure 
3.2). 

Figure 3.2 Capacitor. For simplicity, dielectric bodies are not shown.

The electric-field vector (E) at any point is proportional to Q. The potentials of the bodies (V1 and V2, respectively) 
are also proportional to Q. Hence, the voltage between the first body and the second body (V12=V1−V2) is 
proportional to Q. The voltage can also be evaluated as
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where A and B are arbitrary points on the surfaces of the two conductors. The capacitance of the capacitor is
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The unit for the capacitance of a capacitor is farad (F). In circuit theory, the structure shown in Figure 3.2 is 
represented by a single capacitor, connected between the two bodies, whose capacitance is given by (3.5).

As an example, if we neglect the edge effect, the capacitance of the parallel-plate capacitor shown in Figure 3.3 is C
=ε0S/d, where S is the surface area of each electrode, and d is the distance between the electrodes. Due to the edge 
effect, the actual capacitance is greater than that evaluated by this simple expression.

Figure 3.3. Parallel-plate capacitor.

However, the situation shown in Figure 3.3 (where the conductor charges are opposite and equal in magnitude) is 
not unique. It is possible that the charges of the two conducting bodies are arbitrary, Q1 and Q2. This situation is 
more complicated and is treated in the next section.

3.2.3 Arbitrary Number of Conducting Bodies



We consider the general case of (N+1) conducting bodies (Figure 3.4). Free charges are located only on these 
bodies. We shall refer to the first N bodies as the hot bodies. The last body is the reference body, assumed to be at a 
zero potential. We assume this body to be at infinity. In practical cases, this body is the Earth. 

Figure 3.4 Multiconductor system of N conducting bodies and the reference conducting body at infinity. For 
simplicity, dielectric bodies are not shown.

Let the charges of the hot bodies be Q1,Q2,...,QN. The charge of the reference body is QN+1=−(Q1+Q2+...+QN). Let 
also the potentials of the hot bodies (with respect to the reference body) be V1,V2,...,VN. The charges and potentials 
of the hot bodies are related by a set of linear relations, which we shall consider here.

Assume that only the first hot body is charged with Q1, while all other hot bodies are neutral (uncharged), as shown 
in Figure 3.5. (In this case, the charge of the reference body is QN+1=−Q1.) 

Figure 3.5 The system of Figure 3.4 when all hot bodies are neutral, except for the first body.

Due to the linearity of the system, the potentials of all hot conducting bodies are proportional to Q1, i.e., 
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where a11,a21,...,aN1 are constant quantities for the given system. If the charge Q1 is positive, it is obvious from 
Figure 3.5 that the potentials of all hot bodies are also positive. Hence, all coefficients a11,a21,...,aN1 are positive.

Assume, now, that only the second hot body is charged with Q2, and the other hot bodies are neutral. In this case, 
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We continue with this reasoning, ending with the case in which the last hot body is charged with QN. Now,
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Using the superposition principle, for the case when all hot bodies are charged with Q1,Q2,...,QN, respectively, we 
obtain
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The coefficients aij (i,j=1,...,N) are referred to as the potential coefficients. The unit for these coefficients is V/C 
(which is reciprocal to farad). 

Due to the reciprocity (which holds in electrostatics for linear systems with isotropic media), aij=aji.

Equations (3.9) can be put in matrix form, [V]= [A][Q], where [V] is a column-matrix (a vector) whose elements 
are the potentials of the hot bodies, [Q] is a column matrix whose elements are the charges of the hot bodies, and [A
] is a square matrix (of dimensions N by N) whose elements are the potential coefficients.

We can consider (3.9) as a system of linear equations in terms of the charges. By solving this system in terms of Q1,
Q2,...,QN, we obtain
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where the coefficients bij (i,j=1,...,N) are referred to as the electrostatic-induction coefficients. The unit for these 
coefficients is farad (F). Due to the reciprocity, bij=bji. The coefficients bii (i=1,...,N) are referred to as the self 
coefficients (also known as the capacitance coefficients), whereas all other coefficients (whose indices i and j differ) 
are referred to as the mutual electrostatic-induction coefficients.

In matrix form, (3.10) reads [Q]=[B][V], where [B] is a square matrix (of dimensions N by N), which is the inverse 
of matrix [A], and its elements are the electrostatic-induction coefficients. Matrices [A] and [B] are symmetric.

From (3.10) it follows that the coefficient bij can be evaluated as
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The coefficient bij is evaluated in the situation when all hot bodies are grounded (i.e., galvanically connected to the 
reference body), except for the body labeled j, which is at a potential Vj. (Figure 3.6 shows the case when j=1.) If 
this potential is positive, the charge Qj is also positive, but the charges induced on the other bodies are negative or 
zero. (The induced charge on a conducting body can be zero if that body is completely shielded by another body.) 
Hence, the self coefficients are always positive, whereas the mutual coefficients can be negative or zero.



Figure 3.6 The system of Figure 3.4 when all hot bodies are grounded except for the first body.

The self coefficient bii can be interpreted as the total (equivalent) capacitance between the hot body whose label is i 
and all other bodies (including the reference body) connected together. The mutual coefficient bij equals the 
negative of the mutual capacitance between the hot bodies i and j. This becomes obvious if (3.10) is rearranged as
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is the self capacitance of the hot body i (i.e., the capacitance connected between this body and the reference body) 
and

( )jibc ijij ≠−=)14.3(

is the mutual capacitance between the bodies i and j. All of these capacitances are referred to as partial capacitances. 
They are positive (the mutual capacitances can also be zero in the case of shielding) and cij=cji.

As an example, Figure 3.7 shows an electrostatic system when N=3, along with the corresponding network of partial 
capacitances.

Figure 3.7 Three hot conducting bodies and the equivalent network of partial capacitances.



In numerical techniques for the analysis of electrostatic fields, usually the electrostatic-induction coefficients are 
evaluated first. Knowing these coefficients, the partial capacitances are calculated using (3.13) and (3.14).

3.2.4 Treatment of Capacitances in ES3D

ES3D has a general kernel for the analysis of electrostatic systems. In the program, all conductors (as well as 
dielectrics) are assumed to have finite dimensions. The ES3D kernel can analyze arbitrary structures, starting from 
isolated bodies (as in Figure 3.1) up to multiconductor structures (as in Figure 3.4). ES3D can also analyze 
structures where no conductor is grounded, as well as structures where one conductor is grounded.

The first example of a structure without a ground is one isolated conducting body (such as a square patch printed on 
a PCB with no neighboring ground). In this case, the total number of conductors is 1. Another example is a balanced 
two-wire line, where the total number of conductors is 2. In both cases, no conductor is grounded.

An example of a structure that has a reference conductor (ground) is a PCB that has a ground plane (such as a 
microstrip circuit). Before the PCB is placed into the device under production, the ground plane is floating. Hence, 
the ground plane merely represents a hot conducting body. However, when the device is assembled, the ground 
plane becomes grounded, and its potential is assumed to be zero.

In order to be able to treat all of these cases, the following procedure is implemented in ES3D. The conductors are 
labeled 0,1,2,...,N. In the first step of the analysis, all (N+1) conducting bodies are treated in the same way as the N 
conductors in Figure 3.4. The result of the analysis is the matrix of the electrostatic-induction coefficients [BN+1], 
whose dimensions are (N+1) by (N+1). These coefficients are printed to the output-data file with the default 
extension dat, along with the corresponding partial capacitances.

For example, if the case shown in Figure 3.1 is analyzed, then only Conductor 0 is present. In this case, matrix [BN+1

] consists of only one term, which is the capacitance of the body (as defined in Section 3.2.1). 

For a system in which one conductor is assumed to be the reference conductor, the conductors must be ordered so 
that the reference conductor comes first. The reference conductor is followed by the other (hot) conductors. The 
total number of hot conductors is N. Hence, the reference conductor is labeled 0, and the hot conductors are labeled 
1,2,...,N. 

In the second step of the analysis, the reference conductor is assumed to be grounded (in practice, galvanically 
connected to the Earth). Hence, in equations of the form of (3.10), we set the potential of the first conductor (in 
ES3D, Conductor 0) to be zero. This effectively reduces the dimensions of the matrix of electrostatic-induction 
coefficients to N by N. The new matrix, [BN], is obtained from [BN+1] by deleting the first row and the first column. 
The corresponding partial capacitances form an equivalent network, which is described in the output-data file with 
the default extension ckt. This network is used to evaluate and tabulate the admittance parameters.

Figure 3.8 shows an example for N=1. In the first step of the analysis, three partial capacitances are evaluated. The 
capacitances are labeled using the indexing notation of Section 3.2.3, and they are presented in the dat file. In the 
second step, Conductor 0 is assumed to be grounded. This short-circuits the capacitance c11. The equivalent 
capacitance between Conductor 1 and the reference conductor is c12+c22. Only this equivalent capacitance is 
presented in the CKT file, which is connected between nodes 1 (i.e., Conductor 1) and 0 (ground).



Figure 3.8 Taking one hot body as the reference conductor. 

ES3D also evaluates the admittance (y) parameters of the equivalent network. This network corresponds to the 
output data in the file with the default extension ckt. The matrix of the admittance parameters is evaluated as [Y]=jω[
BN], where ω=2πf is the angular frequency, and f is the frequency. The y-parameters are written to the output-data 
file with the default extension yNp, N=0,1,2,...,9, where N is the number of hot conductors. For N>9, the default 
extension is yN1N2, where N1N2 is the decimal representation of N.

ES3D always evaluates both matrices [BN+1] and [BN], along with the corresponding partial capacitances and the y
-parameters. For the case of an isolated body (N=0), the matrices [BN] and [Y] are empty.



3.3 Numerical Technique

3.3.1 Problem Statement

We consider a system that consists of N conducting bodies and a number of piecewise-homogeneous dielectric 
bodies, as shown in Figure 3.9. The dimensions of all of the bodies are finite. The remaining space is a vacuum.

Figure 3.9 System of N conductors and M piecewise-homogeneous dielectric bodies surrounded by a vacuum.

The objective of the analysis is to evaluate the electrostatic-induction coefficients (self and mutual) of the system. 
These coefficients are calculated from the conductor potentials and charges. The conductor potentials, V1,V2,...,VN, 
with respect to the reference point at infinity, are assumed to be known. The charge distribution is evaluated by 
solving a system of integral equations by using a numerical procedure, as described in the following sections. 

3.3.2 Free and Bound Charges

The primary sources of the electric field are free charges (located on the conductor surfaces). These charges 
produce an electric field, which polarizes the dielectric bodies. The polarized dielectric bodies have an influence on 
the electric field. Physically, this influence is due to the fields of the dielectric molecules. 

Each molecule of a polarized dielectric can be regarded as a tiny electric dipole. Equivalently, the dipole charges 
can be grouped into volume and surface bound charges, assumed to be located in a vacuum. We shall utilize the 
latter concept, in a similar way as in [2]. For a homogeneous dielectric body (with no free charges within its 
volume), there exist only surface charges. Hence, the electric field in the system shown in Figure 3.9 can be 
attributed to the conductor free surface charges, whose density is ρs(r') (where r' is the position vector of the source 
point), and the dielectric bound surface charges, whose density is ρsb(r'). 

The bound charges are located on the surfaces that bound homogeneous dielectric regions. These are interfaces 
between dielectrics and the surrounding vacuum and interfaces between adjacent dielectric regions, as well as 
interfaces between conductors and dielectrics. The first two kinds of interfaces will collectively be referred to as the 
dielectric-to-dielectric interfaces. The third kind of interfaces are actually conductor surfaces.

Mathematically, the free and bound charges at all surfaces are treated together as total charges whose surface 



density is

.)'()'()'()15.3( sbsst rrr ρ+ρ=ρ

The total-charge density is treated as the unknown quantity. It is determined by numerically solving a set of integral 
equations, following the general principles of the Method of Moments [1]. Thereafter, the free charges are extracted 
from the total charges, and the capacitances are calculated easily.

3.3.3 Boundary Conditions and Integral Equations

The first integral equation for the total charges is derived from the boundary conditions for the conductor surfaces, 
in a similar manner as in [2]. For the surface of conductor j, we have
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where r is the position vector of the field point (which can reside anywhere on the surface of conductor j). The 
potential is expressed in terms of the total charges as
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is the free-space Green's function. In (3.16), Si denotes all surfaces of discontinuities. These are conductor surfaces 
(i.e., conductor interfaces with a vacuum or with dielectric bodies) and dielectric-to-dielectric interfaces (which 
include dielectric-to-vacuum interfaces). 

The integral equation based on (3.16) finally reads
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where j=1,...,N, and the field point belongs to the surface Sj of conductor j.

The second integral equation is based on the boundary conditions for the dielectric-to-dielectric interfaces. We 
consider the interface between two dielectrics, whose permittivities are ε1 and ε2, respectively. One of the two media 
can be a vacuum (when the permittivity is ε0). The boundary condition for the normal component of the electric 
field (which is derived from the generalized Gaussian law) reads
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where E1(r)⋅n(r) is the normal component of the electric field in the first dielectric, just at the boundary surface, the 
unit normal vector n(r) of the interface is directed from the second towards the first dielectric, and ρsb(r)=ρst(r) is 



the surface-charge density at the field point. 

Generally, the electric field is evaluated by differentiating the potential as
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By combining (3.17), (3.20), and (3.21), we obtain the integral equation for the dielectric-to-dielectric interface 
considered,
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where V.P. denotes the integration in the principal-value sense.

3.3.4 Solving Integral Equations

Equations (3.19) and (3.22) constitute a system of integral equations, in terms of the total-charge surface density. 
The system is solved numerically, following the Method of Moments [1]. We approximate the unknown charge 
distribution in terms of a finite series of known functions, fk, k=1,...,K, referred to as basis or expansion functions,
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where αk, k=1,...,K, are unknown coefficients yet to be determined, and K is the total number of unknowns for all of 
the surfaces of discontinuities (conductor surfaces and dielectric-to-dielectric interfaces). 

We adopt pulses as the basis functions, which amounts to a piecewise-constant approximation of the charge 
distribution. To that purpose, we divide each conductor surface and each dielectric-to-dielectric interface into a 
number of subdomains that have the form of flat polygonal patches (triangles, quadrilaterals, pentagons, and so on). 
Each pulse is defined on one subdomain (patch), whose surface is denoted by Sk, so that
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The patches need not have the same shape. For example, one can combine quadrilaterals and triangles. In addition, 
the patches can be smaller going toward the edges to provide a better modeling of the edge effect and thus improve 
the convergence of the numerical solution.

The expansion (3.24) is substituted into the integral equations (3.19) and (3.22). 

For testing, we implement the point-matching technique. The matching points are located at patch centroids. By 
imposing the equations to be satisfied at these points, a system of linear equations is obtained in terms of αk.

3.3.5 Evaluation of Integrals

The integrals appearing in the numerical solution can be evaluated explicitly. One class of integrals yields potentials 
due to uniformly charged polygonal plates (Figure 3.10). These integrals are solved as proposed in [3]. The basic 
integrals that have to be evaluated in (3.19) have the common form
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Figure 3.10 Location of the field point M and the patch when the projection M' is outside the patch.

In Figure 3.10, M is the field point and M' is the projection of M onto the plane that contains the patch. The 
projection M' may fall outside the patch (as in Figure 3.10) or inside it (as in Figure 3.11). 

Figure 3.11 Location of the field point M and the patch when the projection M' is inside the patch.

The integral over the patch is broken into integrals over triangles (as shown in Figure 3.10). Skipping further details 
and referring to Figures 3.11 and 3.12, the result is
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where S denotes the polygon surface, Sε is a vanishing circular surface around the point M', ∂S denotes the border of 
the polygon, ∂Sε denotes the border of the circular surface, carets denote unit vectors, and
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Figure 3.12 Notation in (3.26) and (3.27).

Referring to Figure 3.12, the remaining quantities in (3.26) and (3.27) are:
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The second class of integrals yields electric fields due to these plates. The basic integral is obtained by performing 
the differentiation of the potential. In [3], the electric-field integrals are evaluated by numerical differentiation of the 
potential. According to our experience, the numerical differentiation may result in significant numerical errors when 
the field point is close to the source polygon. Hence, we evaluate the electric-field integrals explicitly, as follows:
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When the field point is far away from the source polygon, the closed-form formulas are not computationally 
convenient, and their accuracy is jeopardized. In such cases, the polygon is treated as a point charge, thus avoiding 
the integration. This procedure is simple, sufficiently accurate, and it minimizes round-off errors.

3.3.6 Evaluation of Electrostatic-Induction Coefficients

The resulting system of linear equations is solved using the LU decomposition. As the result, the coefficients αk are 
obtained. Hence, the approximate distribution of the total charges, given by (3.23), is now known.

As the final step, the free charges must be separated from the bound charges to evaluate the capacitances. The 
separation is based on the boundary condition for a zero-thickness conductor surface, where the permittivity of the 
dielectric on one face is ε1, and the permittivity of the dielectric on the other face is ε2. This condition reads [2]
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where the unit normal vector is directed from the conductor surface into the first dielectric.

Once we know the densities of the free charges on each patch, ρsk, the resulting charge on conductor j is given by
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where the summation is performed over all subdomains associated with the conductor considered.

Referring to Section 3.2.3, for a structure that consists of N conducting bodies (assuming the reference conductor to 
be at infinity), the conductor charges and potentials are related as
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where bij, i,j=1,...,N, are the electrostatic-induction coefficients. These coefficients can be evaluated from a set of N 
independent excitations of the system. The simplest way is to assume one conductor to be driven at a potential of 
1V, and all other potentials to be 0 (i.e., these conductors are grounded). 



Once the electrostatic-induction coefficients are known, the self-capacitance of conductor i is evaluated using 
(3.13). The mutual capacitance between conductors i and j is evaluated according to (3.14). 

If one conductor of the system is assumed to be the actual ground of the system (e.g., a ground plane or a shielding 
box), the procedure described in Section 3.2.4 is implemented.



4 Examples

4.1 Introduction

ES3D is distributed with several sample files that illustrate various features of the program. These files contain input 
data for the electrostatic analysis of the following structures:

• Square plate (file Plate.e3d),

• Parallel-plate capacitor (file ParallelPlate.e3d),

• LTCC capacitor (file LTCCCap.e3d),

• Via with pads (file ViaCAD.e3d),

• Combline-filter capacitors (file Combline.e3d),

• Coupled microstrip lines (file Microstrip2.e3d).

These examples are described in the following sections. They complement the examples described in Chapter 2 
(Using ES3D):

• Pads for 0805 SMD components (file 0805Pads.e3d),

• Two plates (file Tutorial.e3d).

Upon installing ES3D, all of these files reside in the subdirectory Examples, accessible from the ES3D root 
directory. All sample files contain complete data about their respective projects. The filename extension of these 
files is e3d. 

The subdirectory Examples also contains sample files for the following topics:

• DXF file import (file ViaCAD.dxf), 

• Stand-alone run of the kernel (file Sphere.lst).



4.2 Square Plate

Input-data file: Plate.e3d

The structure is an isolated square plate, which is located in a vacuum. Its side is a=100 mm. The aim of the 
example is to illustrate the accuracy of computations by ES3D.

The analyzed system has only one conductor, with an index of 0. The capacitance of this conductor is located in the 
output-data file Plate.dat.

By changing the Resolution parameter in the Segmentation tab of the Settings dialog box (accessible from the 
Project menu), one can change the number of unknowns and compare the results for the capacitance with the results 
from [1], as shown below. Please restore the default parameter, Resolution=1, after going through this example. In 
all cases, Refine=1.

ES3D

Resolution Number of patches C [pF]
0.25 9 3.863
1    49  4.007
4    232    4.066

16      680    4.073

Reference [1]

Number of patches C [pF]
36 3.87

100  3.95



4.3 Parallel-Plate Capacitor

Input-data file: ParallelPlate.e3d

The structure is a capacitor that consists of two square plates and is located in a vacuum. The side of each square is a
=1000 mm, and the separation between the plates is d=200 mm. The aim of this example is to consider a system that 
consists of two conducting bodies and compare the field-theory results with the circuit theory visualization.

The structure consists of two conductors. The index of the first conductor is 0, and the index of the second 
conductor is 1. The basic output of ES3D, located in the file ParallelPlate.dat, is the following matrix of 
electrostatic-induction coefficients:

. pF
7.789.54

9.547.78
][ 









−
−

=B

The equivalent scheme is shown in Figure 4.1. The reference point in the scheme is at infinity. The capacitances in 
this scheme (referred to as partial capacitances) are listed as the matrix [C] in the same output file (ParallelPlate.dat
). Their values are c11=23.9 pF, c12=54.9 pF, and c22=23.9 pF.

Figure 4.1 Equivalent scheme of parallel-plate capacitor.

In the circuit-theory visualization, the charges of the two electrodes of the capacitor are always equal in magnitude, 
but opposite in sign. In terms of the partial capacitances, the capacitance of the parallel-plate capacitor is C=c12+c11c
22/(c11+c22)=66.8 pF.

The equivalent scheme in the second output file, ParallelPlate.ckt, is obtained from the scheme shown in Figure 4.1 
by short-circuiting Conductor 0 to the ground. The equivalent scheme consists of a single capacitor, connected 
between Conductor 1 and the ground, whose capacitance is C=c12+ c22=78.7 pF.

The difference between the two results comes from the self partial capacitance of Conductor 0 (c11). Only in cases 
in which the mutual partial capacitance (c12) is much larger than the self capacitances (c11 and c22), the circuit theory 
visualization is a good approximation of a two-conductor system. In other cases, nearby conductors and dielectrics 
influence the equivalent capacitance between the two conducting bodies.

If we neglect fringing fields (i.e., the edge effect), the capacitance is calculated to be C0=ε0a²/d=44.3 pF. The 
numerical result obtained by ES3D, however, demonstrates that the edge effect is strong in this example. The 
capacitance obtained by ES3D (66.8 pF) is substantially greater. This can be explained by the fact that the condition 
d<<a is not met in the present case.



4.4 LTCC Capacitor

Input-data file: LTCCCap.e3d

The structure is a multilayer capacitor in LTCC technology. There are five rectangular plates that are interconnected 
by vias. The relative permittivity of the ceramic material is 7. All layers (except for Layer 0) have the same relative 
permittivity (7). Hence, there are no dielectric-to-dielectric interfaces inside the LTCC structure, as can be seen in 
the 3D view (clipped) shown below. The dielectric-to-dielectric interfaces (green surfaces) exist only on the surface 
of the LTCC device.

If we neglect the edge effects, the structure can be considered as four parallel-plate capacitors connected in parallel. 
The dimensions of the active area of one rectangular plate are 2.2 mm by 1.5 mm, the distance between adjacent 
plates is 0.1 mm, and the total capacitance is 8.2 pF. This agrees fairly well with the capacitance obtained by ES3D, 
which is 8.75 pF. In the present case, the distance between the plates is much smaller than the plate dimensions, so 
the contribution of the edge effect is relatively small.



4.5 Via with Pads

Input-data file: ViaCAD.e3d

This project demonstrates data interchange with AutoCAD®, as well as using vias and overlapped polygons in 
ES3D.

A PCB through via with pads is drawn in AutoCAD 2000®. The resulting file, ViaCAD.dxf (which is supplied as a 
sample file), is loaded into ES3D, where layer properties are defined. The resulting project is ViaCAD, as shown 
below.

In ES3D, one polygon can be drawn within another polygon (in the same layer). The area of the inner (smaller) 
polygon is assumed to be void of metallization. If we draw yet another polygon inside the smaller polygon, we get a 
new metallization pattern. In the present example, we start from the outer rectangle and draw an octagon within the 
rectangle (the larger octagon). The result is an octagonal metallization void. Thereafter, we draw another octagon 
(the smaller octagon), which defines the via pad. A metallization void in the form of an octagonal ring remains, as 
shown below.

To display the void in the Drawing window, the outer rectangle and the larger octagon must be merged into one 



polyline by polyline manipulations.

The structure can be exported to the DXF format using the Export option in the File menu.

The capacitance between the via and the ground is about 0.5 pF.



4.6 Combline-Filter Capacitors

Input-data file: Combline.e3d

This structure is a simplified version of terminal capacitors for an LTCC combline filter. Both self-capacitances (to 
the ground) and mutual (adjacent and nonadjacent) capacitances are provided. Touching polygons belong to one 
conductor. The ceramic block is metallized all over its surface to obtain a closed metallic box. Hence, the structure 
has no dielectric-to-dielectric interfaces. The 3D view of the structure (clipped) is given below.

The resulting network of capacitors is shown in Figure 4.2. The capacitances (from the output file Combline.ckt) 
are: c10=3.393 pF, c12=0.437 pF, c13=0.159 pF, c20=2.598 pF, c23=0.496 pF, and c30=3.704 pF.

Figure 4.2 Equivalent network of partial capacitances for the combline terminal capacitors.

The contribution of vias to the capacitances is small. This can be verified by removing the vias and repeating the 
analysis.



4.7 Coupled Microstrip Lines

Input-data file: Microstrip2.e3d

This project compares the results of 2D and 3D analyses of transmission lines. Two symmetrical coupled microstrip 
lines are considered, on a substrate whose thickness is 0.508 mm (20 mil) and whose relative permittivity is 2.33. 
The width of a strip is 1.5 mm and the separation between the strips is 0.5 mm. The length of the structure is D=
10 mm. The microstrips are shown below.

Linpar [2], with the accuracy parameter set to 4, yields the following matrix of per-unit-length 
electrostatic-induction coefficients (for a finite-width ground plane):

.
m
pF

59.9385.8

85.859.93
]'[ 





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−
−

=B

We have to multiply this matrix by the line length (D=10 mm) to get a result that can be compared with ES3D. Thus 
we obtain

.pF
9359.00885.0

0885.09359.0
][ 









−
−

=B

In ES3D, the Resolution parameter is set to 4, to match the Linpar accuracy parameter, and it yields the following 
result:

B matrix [F]

    1.91623e-012   -8.38377e-013   -8.39166e-013

     -8.373e-013    9.66877e-013   -8.29717e-014

   -8.37484e-013   -8.29777e-014    9.67085e-013

To obtain a matrix that can be compared with the Linpar output, the first row and column of matrix [B] obtained by 
ES3D should be deleted, because Conductor 0 is assumed to be the ground, thus yielding

.pF
9671.008298.0

08297.09669.0
][ 2 
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

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−

=B

The two results are reasonably close to each other. The 2D analysis is more efficient, as it requires fewer unknowns 
for the same accuracy. However, the advantage of 3D analysis is its ability to analyze the effects of discontinuities. 



In this case, edge effects exist at the two ends of the lines.

We can evaluate the edge effects in the following way. We can increase the length of the analyzed structure to 
11 mm. To that purpose, we have to increase the lengths of the footprint, ground metallization, and the two strips. 
ES3D yields the new matrix,

.pF
0610.109144.0

09144.00607.1
][ 2 






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−

=+B

The difference between the two results,

,pF
0939.000846.0

00847.00938.0
][][ 22 
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

−
−

=−+ BB

can be visualized to come from extending the central part of the structure for ∆D=1 mm. Thereby, the fringing fields 
at the two ends of the coupled lines remain intact.

As a byproduct, we have the per-unit-length matrix of electrostatic-induction coefficients, which is obtained by 
dividing this difference by ∆D=1 mm, 

.
m

pF
9.9346.8

47.88.93
]'[ 2 





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This result is closer to the Linpar result than the estimate obtained by dividing matrix [B2] by D.

If we multiply [B2'] by D =10 mm and subtract this result from [B2], we obtain

.pF028.00016.0
0017.0029.0]'[][ 22 



=− BB D

This term comes from the fringing fields at the two line ends. Due to the symmetry, the contributions of the fringing 
fields at the two ends are equal. Hence, the edge effect at one end of the analyzed structure contributes 
approximately by 

.pF
014.00008.0

0008.0014.0
][ 2e 








=B

The equivalent scheme that describes the edge effect at one end consists of three capacitors. A capacitor whose 
capacitance is 0.015 pF is connected between each hot conductor and the ground, and a capacitor whose 
capacitance is −0.0008 pF is connected between the two hot conductors.



5 Reference Manual

5.1 Structures Analyzed by ES3D

ES3D is primarily designed for the electrostatic analysis of 3D multilayer structures. Data input for such structures 
can be performed by using the ES3D graphics editing capabilities or importing a DXF file from other programs. All 
other activities are done within the ES3D environment.

ES3D also has a gateway for the analysis of arbitrarily shaped structures, which need not be layered. All activities 
for this gateway are performed by the user, outside the ES3D environment. The input data for such structures is 
generated by the user and stored in an input-data file. The numerical kernel of ES3D is thereafter used on a 
stand-alone basis. Finally, the results of the analysis are inspected and manipulated by the user.

In the general case, the structure analyzed within the ES3D environment looks as shown in Figure 2.3. The structure 
is confined by a parallelepiped. Within the parallelepiped, the dielectric medium is layered. Metallization patterns 
are located at the interfaces between adjacent dielectrics. The sidewalls of the parallelepiped can be metallized as 
well. The surrounding medium is always a vacuum. A Cartesian coordinate system is associated with the structure, 
so that for any point of the structure x≥0, y≥0, and z≥0 (Figure 5.1). 

Figure 5.1 Bounding parallelepied for the analyzed structure.

The basis of the bounding parallelepiped is the footprint of the analyzed structure. The footprint is rectangular, and 
it is defined by its length (i.e., the dimension along the x-axis) and width (i.e., the dimension along the y-axis). The 
height of the structure is defined by the maximal elevation of dielectric layers above the Oxy plane (Height=zmax).

All parts of the analyzed structure must fit into the footprint and height, i.e., 0≤x≤Length, 0≤y≤Width, and 0≤z≤
Height. If needed, the footprint can be modified by the user. The height is automatically evaluated and updated 
based on the data for the layers. The length and width of the footprint must be positive. The height can be zero if the 
structure consists of only one metallization layer (at z=0).

A dielectric layer occupies the complete footprint. A dielectric layer is defined by its relative permittivity and the 
elevation (z-coordinate) of its upper (top) surface above the Oxy plane (Figure 5.2). The lower surface of the 
dielectric layer coincides with the upper surface of the dielectric layer that is just beneath. The lower surface of first 
layer is always at z=z0=0. The total number of dielectric layers is M, and the layers are counted as 1,2,...,M. The 
layers are ordered according to the z-coordinates of their upper surfaces, so that zmax=zM. The minimal number of 
layers is 0. In this case, the structure consists only of one metallization layer (at z=0).



Figure 5.2 Dielectric layers (side view).

For the structure shown in Figure 5.2, there are two dielectric layers (M=2). The first layer is defined by the z
-coordinate of its upper surface (z1) and its relative permittivity (εr1). The thickness of this layer is z1−z0. Similarly, 
the second layer is defined by the z-coordinate of its upper surface (z2) and its relative permittivity (εr2). The 
thickness of this layer is z2−z1. The height of the bounding parallelepiped is zmax=z2 in this case.

The relative permittivities of the layers may be equal, or they may be different. The relative permittivities can also 
be equal to 1 (as for a vacuum). In the segmentation procedure, no patches are defined for interfaces between two 
dielectric media that have the same relative permittivity.

The metallization layers are located at elevations z0,z1,...,zM. Hence, the total number of metallization layers is M+1. 
The lowest metallization layer (at z0) is at the interface of a vacuum and the lowest (first) dielectric layer, the next 
metallization layer (at z1) is at the interface between the first dielectric layer and the second dielectric layer, and so 
on. The last (highest) metallization layer (at zM) is at the interface between the last (top) dielectric layer and a 
vacuum. The metallization layers are counted as 0,1,2,...,M, as labeled in Figure 2.3. A metallization layer can be 
void of any patterns, when it reduces to a dielectric-to-dielectric interface. In ES3D, the thickness of the 
metallization is always assumed to be zero.

The metallization patterns consist of polygons. Each polygon is bounded by a polyline. A polyline is defined by its 
points (nodes). A polyline must have at least three nonaligned nodes. Polyline segments (edges) must not intersect 
each other. 

A conductor (in the sense of the electrostatic analysis) consists of one or more polygons. In electrostatics, the 
conductor is an equipotential body. Hence, all polygons that belong to one conductor are always at the same 
potential. Polygons that belong to the same conductor are assumed to be galvanically interconnected, even if such 
an interconnection is not explicitly defined in the input data. An example is shown in Figure 2.3, where the large 
patch in Layer 0 and the small patch in Layer 2 both belong to Conductor 0. Conductors are counted as 0,1,2,...,N. 

Conductor 0 is treated in two ways (see Section 3.2.4). In the first case, ES3D treats it as any other hot conductor. In 
the second case, ES3D treats it as being grounded. 

The metallizations of the sidewalls of the bounding parallelepiped are always treated as Conductor 0. The 
metallization for each of the four sidewalls can be defined individually. If it exists, the metallization covers the 
whole sidewall. 

A ground plane at the bottom of the structure can be defined by placing a rectangle all over the bottom surface. This 
rectangle should belong to Conductor 0. In a similar way, a ground plane can be defined at the top of the structure, 
or at any interface between two dielectric layers within the structure. To define a closed metallic box, the top and 
bottom ground planes should be defined, and all four sidewalls should be metallized.

Each polygon belongs to a conductor, which is defined by the conductor index that is associated with the polygon. 
As a rule, each conductor should have at least one polygon. If this rule is violated, all results for a conductor with no 
polygons are zero.



Two polygons (in the same layer) that belong to the same conductor can touch each other, but they must not 
intersect. 

Polygons (in the same layer) that belong to the same conductor can be drawn so that one polygon is completely 
within another polygon. This procedure can be nested. The polyline that bounds the outermost polygon represents 
the outer boundary of the metallized region. The polyline that defines the first inner polygon represents the 
boundary of a metallization void. The polyline that defines the next inner polygon represents the boundary of a 
metallization region, and so on. These polylines must not intersect each other. To display such voids in the Drawing 
window, two-by-two polylines must be merged into reentrant polylines.

A structure can contain vertical metallized holes (vias). A via can start at any layer and end at any higher layer (i.e., 
a layer with a greater z-coordinate). A via galvanically interconnects any penetrating polygon. Hence, all polygons 
penetrated by a via must have the same conductor index (in other words, they must belong to the same conductor). 
In ES3D, a via is modeled by a regular prismatic surface that has at least 3 lateral faces. The top and bottom of a via 
(i.e., the bases of the prismatic surface) can be left open (a hollow via) or covered with metallization (a solid via).



5.2 ES3D Program Modules

ES3D consists of several program modules. The main module is ES3D.exe. It performs the majority of 
user-interface functions and computations. ES3D.exe should be executed to start ES3D. Other executable files and 
dynamic-linked libraries (DLLs) are called from the main module to perform specific actions as needed.

When ES3D.exe is run, the ES3D main window opens. ES3D functions are accessible by using menus and toolbars 
in the ES3D main window.

Several other modules may be of interest to the user. The first one is Capacit.dll, which is the kernel for numerical 
computations. The kernel can be run on a stand-alone basis, using program ES3DKernel.exe. 

The module ES3DView.exe is the 3D viewer. This program controls the ES3D View window. It can also be run on a 
stand-alone basis.

See also: ES3D Main Window; Stand-Alone Solver; 3D Viewer.



5.3 ES3D Main Window

The ES3D main window typically looks as shown below.

The ES3D main window consists of the Drawing area and several menus, toolbars, and bars. Several dialog boxes 
and windows are invoked from the ES3D main window. 

An accompanying window is the Layers window, which is detached from the ES3D main window. The Layers 
window looks as shown below.

The appearance of the ES3D main window can be controlled by using the View menu. The display of the toolbars, 
the Layers window, the Project bar, and the Status bar can be turned on or off individually.

See also: Drawing area; Menus; Toolbars; Project Bar; Layers Window; Status bar.



5.4 Drawing Area

The Drawing area occupies the central part of the ES3D main window. Several projects can be simultaneously 
opened. Each project has its Drawing window, which is located in the Drawing area. In the example shown below, 
only one project is opened and the Drawing window is maximized.

In the Window menu, options are available for arranging the Drawing windows and switching among them.

A Drawing window is used as a graphics interface for defining the multilayer structure to be analyzed.

Each Drawing window has its Control-Menu box , which is used to manipulate the window (resize, move, and 
close) and switch to the next Drawing window. The Control-Menu box appears in the upper-left corner of the 
Drawing window. When the Drawing window is maximized, the Control-Menu box appears in the Menu bar.

See also: Menus; Toolbars; Drawing Polygons; Drawing Vias; Editing. 



5.5 Menus

The ES3D main window has a Menu bar, as shown below.

Available menus and options are as follows:

• File menu handles input-data files:

o Newstarts a new project. Shortcut: Ctrl+N.

o Openopens an existing input-data file (with the default name extension e3d) and thus opens a 
saved project. Shortcut: Ctrl+O.

o Closecloses the currently opened project. Shortcut: Ctrl+W.

o Savesaves the input data that defines the currently opened project. Shortcut: Ctrl+S.

o Save Assaves the input data that defines the currently opened project with a new name.

o Importimports input data from a file in the DXF format.

o Exportexports input data to a file in the DXF format.

o Exitcloses ES3D. Shortcut: Alt+F4.

The File menu also contains a list of the four most recently opened input-data files, which enables quick access 
to these files.

• Edit menu handles the current drawing:

o Undoundoes the last operation in a Drawing window (up to 20 steps). Shortcut: Ctrl+Z.

o Redoredoes the last undo (up to 20 steps). Shortcut: Ctrl+Y.

o Cutdeletes selected objects (polygons and vias) and places them into the Paste buffer. Shortcut: 
Ctrl+X.

o Copycopies selected objects into the Paste buffer. Shortcut: Ctrl+C.

o Pastepastes the contents of the Paste buffer slightly offset with respect to the original position. 
Shortcut: Ctrl+V.

o Paste to Original X,Ypastes the contents of the Paste buffer exactly to the original position. 
Shortcut: Ctrl+T.

o Deletedeletes the selected objects (without placing the deleted objects into the Paste buffer).

o Select Allselects the complete drawing. Shortcut: Ctrl+A.



• View menu handles the layout of the ES3D main window and the appearance of the current drawing:

o Toolbarsdefines which toolbars are displayed:

� Standard

� Tools .

� Info .

� Compute .

o Layersdefines if the Layers window is open or not. The Layers window is shown below.

o Project Bardefines if the Project bar is visible or not. The Project bar is an area in the left part 
of the ES3D main window that looks as shown below.

o Status Bardefines if the Status bar is visible or not. The Status bar is an area in the bottom part 
of the ES3D main window that looks as shown below.

o Panturns panning on and off. Panning is done using the mouse in a drag-and-drop fashion. 
Shortcut: Ctrl+H.

o Zoomturns on the Zoom tool. Shortcut: F8.

o Zoom Inzooms in for one step. Shortcut: Numpad +.

o Zoom Outzooms out for one step. Shortcut: Numpad −.



o Zoom Allzooms the whole drawing. Shortcut: Ctrl+ F8.

o Show Gridturns the grid display on and off. The grid step is defined in the Settings dialog box.

o Snap to Gridturns the grid snap on and off. If it is turned on, all points can be drawn only at 
grid nodes.

o Draw Modeselects the way that polygons are displayed. Two options are available:

� Normalthe bounding polyline is drawn and the area bounded by the polyline is filled 
with a color (if the polyline is closed).

� WireFrameonly the bounding polyline is drawn.

o 3D Viewopens the ES3D View window, where the segmented structure can be displayed. 
Shortcut: Ctrl+F4.

o Propertiesif one drawing object is selected (a polyline or a via), properties of that object are 
displayed. Shortcut: Alt+Enter.

• Arrange menu manipulates polygons: 

o Bring to Frontbrings the selected polygon in front of other polygons in the layer. Shortcut: 
Ctrl+F.

o Send to Backbrings the selected polygon behind other polygons in the layer. Shortcut: Ctrl+B.

o Subtractcreates metallization voids from a pair of polylines.

• Draw menu starts drawing various objects:

o Polylinedraws a polyline. Shortcut: F4.

o Rectangledraws a rectangle. Shortcut: F5.

o Viadraws a via. Shortcut: F6.

• Project menu inserts new objects into the drawing and enables various settings:

o New Layeropens the New Layer dialog box in which parameters that define a new layer can be 
entered. The parameters are the layer name, the z-coordinate of the upper surface of the dielectric 
layer, and the dielectric relative permittivity. In this dialog box, it is also possible to define if the 
layer is visible or not and if it is locked or not. Shortcut: Ctrl+L.

o New Polygonopens the Polygon dialog box in which a polygon can be defined by supplying 
data numerically. The data that defines the polygon consists of the index of the conductor to 
which the polygon belongs, the name of the metallization layer in which the polygon is located, 
and the x and y coordinates of nodes (points) that define the bounding polyline. In this dialog box, 
it is also possible to define if the polyline is closed or not.

o New Viaopens the Via dialog box in which a via can be defined by supplying data numerically. 
The data that defines the via consists of the x and y coordinates of the via center, the via radius, 



and the names of the top and bottom metallization layers, between which the via extends. In this 
dialog box, it is also possible to define if the via is opened (hollow) or if it has two caps (solid).

o Footprintdefines the dimensions of the footprint that bounds the drawing.

o Metallizationdefines the metallization of the four sidewalls of the structure.

o Settingsopens the Settings dialog box. This box has five tabs:

� Unitsdefines units for coordinates and frequency. These units are applied to all 
respective quantities within the current project.

� Frequenciesdefines the equidistant frequencies at which the admittance parameters 
are tabulated. The frequencies are defined by the start frequency, the stop frequency, and 
the number of frequency steps.

� Segmentationdefines the segmentation parameters.

� Editordefines the grid spacing and default footprint that is used when a new project is 
started.

� Outputdefines which output files are to be listed when clicking the List Results button 
and in the AutoRun sequence.

• Compute menu starts operations necessary to numerically analyze the structure:

o Checkchecks the input data for consistency. Shortcut: Ctrl+F2.

o Segmentdivides the metallic and dielectric surfaces into patches. Shortcut: Ctrl+F3.

o Runruns the kernel for the numerical analysis. Shortcut: Ctrl+F5.

o AutoRunexecutes checking, segmentation, running the kernel, and listing output results in a 
sequence. Shortcut: Ctrl+F6.

• List menu invokes Notepad to display the output files that contain the results of the numerical analysis:

o C Parametersopens the file with the electrostatic-inductance coefficients and the partial 
capacitances.

o Cktopens the file with the equivalent circuit that represents the analyzed structure.

o Y Parametersopens the file with the tabulated admittance parameters of the equivalent circuit.

• Window menu manages the opened Drawing windows:

o Cascadecascades the Drawing windows.

o Tiletiles the Drawing windows.

o Arrange Iconsarranges the icons of the minimized Drawing windows.



The Window menu also contains a list of opened Drawing windows. This list can be used to switch quickly 
among the windows.

• Help − opens the ES3D Help window and displays the copyright data:

o Contentsopens the Table of Contents of the ES3D Help. Shortcut: F1.

o About ES3Dshows the copyright information about ES3D.



5.6 Toolbars

The following toolbars are available in the ES3D main window:

• Standardduplicates the most common commands from the menus:

o Newsame as the New option in the File menu. Shortcut: Ctrl+N.

o Opensame as the Open option in the File menu. Shortcut: Ctrl+O.

o Savesame as the Save option in the File menu. Shortcut: Ctrl+S.

o Cutsame as the Cut option in the Edit menu. Shortcut: Ctrl+X.

o Copysame as the Copy option in the Edit menu. Shortcut: Ctrl+C.

o Pastesame as the Paste option in the Edit menu. Shortcut: Ctrl+V.

o Zoom Insame as the Zoom In option in the View menu. Shortcut: Numpad +.

o Zoom Outsame as the Zoom Out option in the View menu. Shortcut: Numpad −.

o Zoom Allsame as the Zoom All option in the View menu. Shortcut: Ctrl+F8.

• Toolsprovides drawing tools (cursors):

o Select Objectpointer for selecting a drawing object. This tool is also used for drag-and-drop 
editing, moving polygons and vias, and stretching polygons. Shortcut: F2.

o Polygon Nodepointer for drag-and-drop editing of polyline nodes (moving). Shortcut: F3.

o Polylinepointer for drawing polylines. Shortcut: F4.

o Rectanglepointer for drawing rectangles. Shortcut: F5.

o Viapointer for drawing vias. Shortcut: F6.

o Handpointer for panning the drawing. Shortcut: F7.

o Zoompointer for zooming the drawing. Shortcut: F8.

With any of these pointers, clicking the right mouse button opens the Context menu that can be used for 
editing polylines and vias.

• Infoprovides information about the current coordinates of the drawing cursor and properties of the 
current layer. In the Layer menu, the currently active layer can be changed.



.

• Computeduplicates some options from the menus:

o Checksame as the Check option in the Compute menu. Shortcut: Ctrl+F2.

o Segmentsame as the Segment option in the Compute menu. Shortcut: Ctrl+F3.

o 3D Viewsame as the 3D View option in the View menu. Shortcut: Ctrl+F4.

o Runsame as the Run option in the Compute menu. Shortcut: Ctrl+F5.

o AutoRunsame as the AutoRun option in the Compute menu. Shortcut: Ctrl+F6.

o List Resultslists the default output-data files. Shortcut: Ctrl+F7.

The toolbars can be displayed or removed from the ES3D main window using the Toolbars option in the View 
menu. In the corresponding submenu, check the toolbars that you want to be displayed.



5.7 Project Bar

The Project bar is an area located in the left part of the ES3D main window. Its visibility is controlled by the Project 
Bar option in the View menu. The Project bar contains summary information about layers, polygons, and vias. 
Initially, the Project bar looks as shown below.

Information about layers and vias can be expanded by clicking the Expand buttons .When all items are expanded, 
the Project bar looks like the example below.

The Project bar lists all layers, polygons, and vias, giving IDs of these objects. 

The Project bar can be used to change the current drawing layer. Left-click a layer name to make it become the 
active layer. 

The Project bar can be used to modify layer properties. Right-click a layer name to open the Context menu, which 
has the following options:

• Deletedeletes the layer. 

• Propertiesopens the Properties dialog box, where you can change various parameters that define the 
layer.

A layer can also be deleted by selecting it and pressing the Delete key.

The Project bar can be used to select an object (a polygon or a via). This is particularly convenient for an object that 
is hidden by other objects drawn in higher layers. Left-click a polygon or a via to select it. Right-click it to open the 
Context menu, which has the following options:



• Cutdeletes and moves the object to the paste buffer.

• Copycopies the object to the paste buffer.

• Pastepastes the object from the paste buffer at a location slightly offset from the original (x,y) location 
in the active layer. An object can be copied from one layer and pasted into another layer.

• Paste to Original X,Ypastes the object from the paste buffer to the original (x,y) location in the active 
layer. An object can be copied from one layer and pasted into another layer.

• Deletedeletes the object without moving it to the paste buffer.

• Bring to Frontavailable only for polygons; brings the polygon in front of the other polygons in the 
active layer.

• Send to Backavailable only for polygons; brings the polygon behind the other polygons in the active 
layer.

• Indexavailable only for polygons; opens the Index dialog box in which one can change the index of the 
conductor to which the polygon belongs.

• Propertiesopens the selected object's dialog box (polygon or via) in which one can change all of its 
properties.



5.8 Layers Window

The Layers window opens detached from the ES3D main window and it contains information about layers. The 
Layers window is shown below.

The Layers window is displayed if the Layers option in the View menu is selected. It is recommended that the 
Layers window always be open, as the best layer control is achieved from it. 

The Layers window can be used to change the current drawing layer. Left-click a layer name to make it the active 
layer.

The layer properties can be modified by double-clicking a layer name. The Layer Properties dialog box opens, as 
shown below.

In this box, all of the properties that define the layer can be modified. This box has the same functionality as the 
New Layer dialog box.

Right-clicking a layer name in the Layers window opens the same Context menu as from the Project bar, with the 
options of Delete and Properties. A layer can also be deleted by selecting it and pressing the Delete key.

To quickly toggle between the visible and invisible states of a layer, click the Visibility icon  in the Layers 
window. 

To quickly lock or unlock a layer, click the Lock icon  in the Layers window.

To modify layer colors, click the Color icon  in the Layers window. The Color dialog box appears as shown 
below.



Follow the standard Windows procedure to modify the color.



5.9 Status Bar

The Status bar is an area in the bottom part of the ES3D main window Its visibility is controlled by the Status Bar 
option in the View menu. The Status bar looks as shown below.

The left part of the Status bar contains information about the status of the ES3D main window (Ready/Busy) and 
about various items that are currently under the cursor: 

• For a polygon, its ID is displayed along with the index of the conductor to which the polygon belongs. 

• For a via, its ID is displayed along with the elevations (z-coordinates) of its top and bottom layers. 

• For a button, the button name and shortcut are displayed.

The right part of the Status bar shows the footprint dimensions.

See also: ES3D Main Window.



5.10 Project Settings

Project settings are made by selecting the Settings option in the Project menu. The Settings dialog box opens as 
shown below.

Settings are applied to the currently opened project. They are also used as the default settings for new projects, as 
long as the settings are not modified.

The Settings dialog box has five tabs, with the following functions:

• Unitsdefines units for coordinates (lengths) and frequencies. This tab is shown above. 

o Available units for coordinates are millimeter (mm), meter (m), inch (inch), and mil (mil). Click 
the corresponding radio button to select.

o Available units for frequencies are kilohertz (kHz), megahertz (MHz), and gigahertz (GHz). Click 
the corresponding radio button to select.

• Frequenciesdefines the start frequency, the stop frequency, and the number of frequency steps for 
tabulating the admittance parameters. The Frequencies tab looks as shown below.

The start frequency must be positive or zero. The stop frequency cannot be smaller than the start 
frequency. The number of frequency steps must be positive or zero. 



If the stop frequency is set equal to the start frequency, the program sets the number of frequency steps to 
0. If the number of frequency steps is entered as 0, the program sets the stop frequency equal to the start 
frequency. In both cases, the admittance parameters are evaluated only at one frequency.

In the above example of the Frequencies tab, the admittance parameters are tabulated at the following 
frequencies: 0, 0.5 GHz, 1 GHz, 1.5 GHz, and 2 GHz.

• Segmentationdefines the parameters for the self-adaptive segmentation. The tab looks as shown below.

The Resolution and Refine parameters must be positive. The recommended value for both parameters is 1. 
It is not recommended to use values less than 1. The number of via segments must be at least 3 and at most 
16.

• Editordefines the grid spacing and the default footprint. The Editor tab looks as shown below.

The grid spacing is uniform with equal steps in both coordinates (x and y). The grid spacing must be 
positive. 

If the Default footprint checkbox is checked, the default footprint is used for all new projects. The 
dimensions of the default footprint are defined in this dialog box. 

• Outputdefines output files that are displayed automatically upon clicking the List Results button and at 
the end of the AutoRun sequence. The Output tab looks as shown below.



One, two, or three files can be checked. At least one filename must be checked.

Click the OK button to accept the changes, and close the Settings dialog box. Click the Cancel button if you want to 
reject the changes.

See also: ES3D Main Window.



5.11 Arranging Windows

Up to ten projects can be concurrently opened in ES3D. Each project has its Drawing window, which is opened in 
the Drawing area. These windows can be arranged using the options in the Window menu. 

A window can be maximized to occupy the whole Drawing area. If the window is maximized, its control buttons 

appear just below the control buttons for the ES3D main window . Closing a Drawing window also 
closes the corresponding project.

If windows are not maximized, they can be cascaded or tiled, which is determined by selecting the corresponding 
option in the Window menu. 

A minimized window appears as an icon. Icons can be arranged using the corresponding option in the Window 
menu. 

The Window menu contains a list of currently opened Drawing windows. This list can be used to switch among the 
Drawing windows.

The Drawing windows can also be manipulated using the Control-Menu box  located in the upper-left corner of 
each window. If the Drawing window is maximized, the Control-Menu box appears in the ES3D main window 
menu bar.

See also: ES3D Main Window.



5.12 Help

ES3D Help uses standard Microsoft Windows® Help services. Help is available in ES3D by pressing the F1 key or 
by using the Help menu. 

Help for most ES3D windows and dialog boxes is located in the file ES3D.hlp. For the ES3D View window, a brief 
Help is located in the file ES3D_View.hlp. Both files reside in the ES3D root directory. 

The Help files can be opened directly from Windows. Locate a file using Windows Explorer, and double-click the 
filename or its icon.

See also: Using ES3D Help; ES3D Main Window.



5.13 Analysis Cycle

A typical cycle of the electrostatic-field analysis using ES3D consists of the following steps:

• Defining input data.

• Segmenting the structure.

• Displaying a 3D view of the structure.

• Running the analysis.

• Displaying results.

All of the above steps are necessary, except for the 3D view. 

Segmenting the structure, running the analysis, and displaying the results can be performed by a single command 
(AutoRun).



5.14 Defining Input Data

To enter input data that defines a structure to be analyzed, several steps have to be performed:

• Starting a new project.

• Defining footprint and sidewall metallization.

• Defining layers.

• Drawing and editing polygons and vias.

• Saving input data.

• Checking input data.

These steps are performed in the ES3D main window. Except for the first step, the steps need not always be 
performed in the above order. 

The checking step may be skipped, as it is automatically done before segmenting the structure.

After performing the analysis, the input data can be modified at will, and the analysis can be performed again.

See also: ES3D Main Window.



5.15 Starting New Project

To start a new project, perform the following steps:

• Go to the ES3D main window.

• In the Settings dialog box, select the unit for coordinates. This dialog box is accessible by selecting the 
Settings option in the Project menu.

• Select the New option in the File menu. The New Project dialog box opens as shown below.

• In the New Project dialog box, enter the footprint dimensions.

• In the Settings dialog box, define the frequencies for tabulating the admittance parameters, segmentation 
parameters, grid spacing, and the default output files, as needed.

• To define the project name, select the SaveAs option in the File menu and save the project.

See also: ES3D Main Window; Menus; Project Settings; Defining Footprint.



5.16 Defining Footprint

The footprint is defined when starting a new project in the New Project dialog box. The default dimensions of the 
footprint in this box are identical to the dimensions used for a previous new project. Alternatively, the default 
footprint can be defined in the Editor tab of the Settings dialog box.

The footprint for an open project can be modified by using the Footprint option in the Project menu. The 
dimensions of the footprint cannot be reduced so that objects (polygons or vias) fall outside the footprint. 

See also: ES3D Main Window; Starting New Project.



5.17 Defining Sidewall Metallization

A multilayer structure has four vertical sidewalls (Figure 5.1). These walls correspond to x=0 (left), x=Length 
(right), y=0 (front), and y=Width (rear), where Length and Width are the dimensions of the footprint.

A sidewall can be void of metallization, or it can be completely covered with metallization. The metallization 
always belongs to Conductor 0.

To define if the metallization is present or not, select the Metallization option in the Project menu. The 
Metallization dialog box opens as shown below.

Each sidewall has an associated button. If a button is depressed, the associated sidewall is metallized. If a button is 
released, the associated sidewall is void of metallization. Click the buttons to change the sidewalls’ states, as 
appropriate. Click the OK button to accept the changes, and close the Metallization dialog box. Click the Cancel 
button if you want to reject the changes.

A wall that is metallized is displayed in red in the Drawing window, but it is black otherwise. In the ES3D View 
window, a metallized wall has the color of Conductor 0 (blue). A wall that is not metallized has the color of a 
dielectric (green).

See also: ES3D Main Window.



5.18 Defining Layers

When a new project is opened, the lowest layer is automatically defined. Its default name is Layer 0 (which can be 
changed at will), the elevation is z=0, and the relative permittivity is 1. In a project, there must always be a layer 
whose elevation is z=0. The relative permittivity for that layer must always be 1.

To define a new layer, perform the following steps:

• In the Project menu, select the New Layer option. Alternatively, press the Ctrl+L key in the ES3D main 
window. The New Layer dialog box opens as shown below.

• In the New Layer dialog box, enter the relative permittivity of the dielectric and the z-coordinate of the 
upper surface of the dielectric. This coordinate is the elevation above the Oxy plane at which the 
metallization pattern is created. When entering the coordinate, you can select the unit. This selection is 
temporary and only affects the present instance of the dialog box. In this dialog box, you can also modify 
the layer name and define if the layer is visible and if it is locked.

You can define new layers, as necessary, up to a maximum of 10 layers. New layers can be defined at any time 
during the process of entering the input data.

To modify an existing layer, perform the following steps:

• In the Layers window, double-click the layer name. Alternatively, in the Layers window or in the Project 
bar, right-click the layer name to open the Context menu, and then select the Properties option. The Layer 
Properties dialog box opens.

• The Layer Properties dialog box is identical to the New Layer dialog box shown above. In it, you can 
modify the data that defines the layer. An exception is the lowest layer, for which the elevation (z=0) and 
the relative permittivity (1) cannot be modified.

• To quickly toggle between visible and invisible states of a layer, click the Visibility icon  in the Layers 
window. Making a window invisible may help in viewing patterns in lower layers.

• To quickly lock or unlock a layer, click the Lock icon  in the Layers window. Making a layer locked 
prevents the user from accidentally modifying the patterns in that layer.



• To modify layer colors, click the Color icon  in the Layers window. Follow the standard Windows 
procedure to modify the color.

• To delete a layer, select the layer in the Project bar or in the Layers window and press the Delete key. 
Alternatively, select the layer, open the Context menu, and select the Delete option.

To make a layer active for drawing, click the layer name in the Project bar, the Layers window, or the Info toolbar.

See also: ES3D Main Window; Layers Window; Project Bar; Toolbars.



5.19 Grid

The footprint area in a Drawing window can be gridded. The grid is uniform in both coordinates (x, y). The grid 
begins at the coordinate origin (i.e., at the lower-left corner of the drawing). 

The grid step can be adjusted in the Editor tab of the Settings dialog box. This box is opened by selecting the 
Settings option in the Project menu.

The display of the grid can be turned on and off by checking and unchecking the Show Grid option in the View 
menu. 

Drawing and drag-and-drop editing of polylines (including rectangles) and vias can snap to the grid. The snap can 
be turned on and off by checking the Snap to Grid option in the View menu.

See also: ES3D Main Window.



5.20 Drawing Polygons

Metallization patterns in layers are drawn as polygons. A polygon is bounded by a polyline, which consists of 
straight-line segments (edges) and is defined by points (nodes). A polyline must have at least three nonaligned 
nodes, and the upper limit set by the program is 50. 

All points of a polyline have the same z-coordinate. That is the coordinate of the layer in which the polyline is 
drawn. A polygon must be positioned completely within the footprint.

A polyline can be drawn open or closed. This choice is irrelevant for the computations, as the polyline is always 
considered to be closed. The only difference is in the visual representation of the polyline. A closed polyline is 
filled in the normal draw mode, unlike an open polyline. Polyline edges must not intersect. 

A polyline can be convex, concave, or reentrant, as shown below.

A polyline can be drawn using the mouse. Alternatively, its nodes can be entered numerically.

To draw the polyline using the mouse, perform the following steps:

• Make active the layer in which you want to draw the polyline.

• Select the Polyline tool  in the Tools toolbar or select the Polyline option in the Draw menu. 

• Left-click the mouse at the location of the first point. Release the left mouse button.

• Left-click the mouse again, drag the next point to the desired location (as shown below), and release the 
left mouse button. Repeat as necessary to draw all points. 

• If the last point drawn coincides with the first point, the polyline is assumed to be closed and the last point 
is discarded. Otherwise, the polyline is assumed to be open.

• Press the C key on the keyboard immediately after drawing the last point to close the polyline. The polyline 
can also be closed later, by editing its properties.



• Press the I key on the keyboard immediately after drawing a closed polyline to open the Conductor Index 
dialog box, where you can define the index of the electrostatic conductor to which the polygon belongs, as 
shown below.

The index can also be defined later, by editing the polygon properties.

To enter node coordinates numerically, select the New Polygon option in the Project menu. The Polygon dialog box 
opens as shown below.

In the Polygon dialog box, define the index of the conductor to which the polyline belongs, select the layer in which 
the polyline is drawn, enter the coordinates (x,y) for at least three nodes, and check the box that defines if the 
polyline is closed. Click the OK button when done.

The Polygon dialog box shown above also opens when editing properties of a polygon. The node coordinates can be 
edited in this box. To insert a node or delete a node, right-click the entry for the coordinate x or y of a node. The 
Context menu opens, with options to insert a node before the selected node or to delete the selected node.

A rectangle can be drawn using the Rectangle tool  in the Tools toolbar or by selecting the Rectangle option in 
the Draw menu. Left-click the mouse at the position of one node of the rectangle. Drag-and-drop the other point to 
stretch the rectangle diagonal. After a rectangle is drawn, it is treated as any other polygon with four nodes.

A reentrant polyline has pairs of coinciding edges. In the following example, there exists one pair of coinciding 
edges.



The polyline defines one outer boundary and one inner boundary. The area between these boundaries is metallized, 
and the area within the inner boundary is void of metallization. Hence, this reentrant polyline defines an annular 
metallization pattern. The senses of the outer and inner boundaries must be opposite. For example, if the nodes on 
the boundary are ordered counterclockwise, the nodes on the inner boundary must be ordered clockwise. Hence, the 
reentrant polyline can be visualized as the result of closing the gap (cut) of the polygon shown below.

The coinciding edges of a reentrant polygon do not violate the nonintersecting rule for the polygon edges. 

No two polylines belonging to different conductors can touch or intersect. Two polylines belonging to the same 
conductor can be drawn so they touch each other, but they must not intersect.

Two polylines belonging to the same conductor and the same layer can also be drawn so that one polyline is 
completely within the other polyline. Such a pair of polylines defines an annular metallization pattern in the same 
way as a reentrant polyline. The metallization is in the area bounded by the two polylines. The area bounded by the 
inner polyline is void of metallization. An example is the via with pads. 

The void area is created during the segmentation of the structure, and it can be seen only in the 3D view. To see the 
void in the Drawing window, the two polylines must be merged into one reentrant polyline, using the following 
procedure:

• Select the outer polyline using the Select Object tool  in the Tools toolbar.

• Hold down the Shift key or the Ctrl key and select the inner polyline.

• Once the two polylines are selected, open the Arrange menu and select the Subtract option.

For example, when this procedure is applied to the via with pads, the Drawing window looks as shown below.



This procedure can be nested. Several polygons can be drawn so that one polygon is completely in the interior of 
the previous polygon. To obtain meaningful results in the Subtract procedure, always merge pairs of polylines by 
starting from the two outermost polylines.

See also: ES3D Main Window.



5.21 Drawing Vias

A metallized hole (via) interconnects polygons that are located in different layers, but all belong to the same 
electrostatic conductor. The via extends between two layers in the multilayer structure. It can be a buried via, a 
blind via, or a through via. 

All polygons that are penetrated by the via are automatically interconnected. The via must penetrate at least one 
polygon. The via must not interconnect polygons that belong to different electrostatic conductors. 

In the drawing, a via is represented by a circle. The circle that represents the via must be completely within the 
polygon (i.e., the circle and the polygon must not intersect).

A via can be drawn in two ways. The first way combines the mouse and numerical entries. The second way is purely 
numerical.

The first way consists of the following steps:

• Select the Via tool  in the Tools toolbar or select the Via option in the Draw menu. 

• Left-click the mouse at the location of the via center. Release the left mouse button. The Via dialog box 
opens as shown below.

In the Via dialog box, the coordinates (x,y) are already defined by the mouse click. You have to enter the via radius, 
specify the top and bottom layers between which the via extends, and define if the via is solid or hollow. The 
elevation of the top layer must be higher than the elevation of the bottom layer. The two layers cannot coincide. 
Click the OK button when done.

The second way to define a via consists of selecting the New Via option in the Project menu. The same Via dialog 
box opens, as shown above. The coordinates (x,y) now have to be supplied numerically. The other steps are same as 
in the first way of defining a via.

The Via dialog box shown above also opens when editing the properties of a via.

See also: ES3D Main Window.



5.22 Editing

A drawing produced in the Drawing window can be edited (modified) using various features provided in ES3D. 

Actions are performed on polygons or vias that are selected in the active Drawing window. 

5.22.1 Selecting Objects

To select one object (one polygon or one via), perform one of the following actions:

• Activate the Select Object tool  in the Tools toolbar. Place the arrow pointer above the object and 
left-click the mouse.

• Left-click the polygon or via in the Project bar.

To select multiple objects, perform one of the following steps:

• Activate the Select Object tool in the Tools toolbar. Stretch a rectangular area that encompasses all objects 
to be selected. To stretch the rectangular area, position the pointer at one corner of the area, click the left 
mouse button, drag the pointer to extend the area as desired, and then release the mouse button.

• Activate the Select Object tool in the Tools toolbar, and hold down the Shift or the Ctrl key. Place the 
arrow pointer above objects one-by-one, and left-click the mouse.

To select all polygons and vias in the drawing (in layers that are visible and unlocked), use the Select All option in 
the Edit menu 

5.22.2 Menu Editing

Various editing functions can be performed using options in the ES3D main window Edit menu and Arrange menu, 
as well as in the Context menu. (The Context menu is a menu that opens by right-clicking the selected object or 
right-clicking the object name in the Project bar.) 

The following actions can be performed with a polygon or a via that are selected:

• Cutdeletes and moves the object to the paste buffer. Select the Cut option in the Edit menu or in the 

Context menu, or click the Cut button  in the Standard toolbar.

• Copycopies the object to the paste buffer. Select the Copy option in the Edit menu or in the Context 

menu, or click the Copy button  in the Standard toolbar.

• Pastepastes the object from the paste buffer to a location slightly offset from the original (x,y) location 
in the active layer. (An object can be copied from one layer and pasted into another layer.) Select the Paste 

option in the Edit menu or in the Context menu, or click the Paste button  in the Standard toolbar.

• Paste to Original X,Y pastes the object from the paste buffer to the original (x,y) location in the active 
layer. (An object can be copied from one layer and pasted into another layer.) Select the Paste to Original 
X,Y option in the Edit menu or in the Context menu.

• Deletedeletes the object without moving it to the paste buffer. Select the Delete option in the Edit menu 



or in the Context menu, or press the Delete key on the keyboard.

• Bring to Front available only for polygons; brings the polygon in front of the other polygons in the 
active layer. Select the Bring to Front option in the Arrange menu or in the Context menu.

• Send to Backavailable only for polygons; brings the polygon behind the other polygons in the active 
layer. Select the Send to Back option in the Arrange menu or in the Context menu.

• Propertiesopens the selected object's dialog box (polygon or via) in which one can change all of its 
properties.

From the Context menu for a selected polygon, one can directly change the index of the conductor to which the 
polygon belongs.

The Cut, Copy, Paste, Paste to Original X,Y, and Delete operations also work if all of the objects are selected. 
When pasting, all selected objects are always pasted to the currently active layer.

5.22.3 Drag-and-Drop Editing

Using drag-and-drop graphical editing, the selected polygon or via (or all selected objects) can be moved.

Additional drag-and-drop editing can be performed on polygons, as follows: 

• Use the Select Object tool  in the Tools toolbar to select a polygon. The selected polygon looks as 
shown below.

Four handles are visible, which define a rectangle that bounds the polygon. Grab one of the four handles by 
clicking it. Drag-and-drop to resize the rectangle.

• Use the Polyline Node tool  in the Tools toolbar to select a polygon. The selected polygon looks as 
shown below. 

Handles are visible for each polygon node. Grab a handle by clicking it. The selected handle becomes red.

Clicking a polygon edge selects the handles for the two nodes that belong to that edge.



Two or more nodes of one polygon can be selected by holding down the Shift or the Ctrl key and clicking 
the handles one-by-one. Alternatively, stretch a rectangular area to select all nodes that are within the area. 

If several polygons had been selected by the Select Object tool before activating the Polyline Node tool, 
multiple handles can be selected in the same way as they are for one polygon.

Drag-and-drop to move the selected node(s).

5.22.4 Other Editing Features

The Subtract operation is available for polygons to display metallization voids. This operation handles two polygons 
that belong to the same layer and the same conductor, when one polygon completely resides within the other 
polygon.

A layer can be edited by selecting it and opening the Layer Properties dialog box.

The footprint can be edited using the Footprint option in the Project menu.

Undo and Redo features are available by selecting the corresponding option in the Edit menu. Up to 20 last drawing 
steps (including editing) are handled in each Drawing window.

See also: ES3D Main Window.



5.23 Viewing

Several options and functions are available to facilitate viewing the structure drawn in the Drawing window.

Polygons can be displayed in two modes: 

• Normal modethe contour of the polygon is drawn. If the polygon is defined to be closed, the interior is 
filled, using the color of the corresponding layer in which the polygon is located. (In the segmentation 
procedure and in the numerical analysis, closed and open polygons are treated in the same way.)

• WireFrame modeonly the polygon contour is drawn.

The selection is made using the Draw Mode option in the View menu.

The layers are displayed in the Drawing window, so that a layer with a higher elevation is drawn over a layer with a 
lower elevation. Thus, polygons and vias in lower layers can be partly or totally hidden by objects in higher layers. 

In order to see a complete layer, all higher layers can quickly be turned off by using the Visibility icon  in the 
Layers window.

The drawing can be panned (translated) and zoomed. A drawing can be panned only if it is zoomed in. 

To pan the structure, the following functions are available:

• Select the Hand tool  in the Tools toolbar. Left-click anywhere on the drawing and drag it.

• Use the horizontal and vertical slides.

• Shift+Mouse wheel pans up/down. Ctrl+Mouse wheel pans left/right.

To zoom the structure, the following functions are available:

• Zoom tool, which can be activated by selecting the Zoom option in the View menu or clicking the Zoom 

tool  in the Tools toolbar. When the Zoom tool is active, the zoom cursor is in effect. Using this 
cursor, click anywhere on the drawing to zoom in around the cursor. To zoom out, press and hold the Shift 
key on the keyboard, and then click on the drawing (Shift+click). To zoom a rectangular area, select it by 
using the mouse. 

• ZoomIn and ZoomOut options in the View menu, which are duplicated by the ZoomIn and ZoomOut 

buttons  in the Standard toolbar. Zoom in and out is performed around the center of the drawing.

• ZoomAll option in the View menu, which is duplicated by the ZoomAll button in the Standard toolbar. The 
complete drawing is fit into the Drawing window.

• Mouse wheel, which zooms in and out around the cursor.

A 3D view of a segmented structure is available by selecting the 3D View option in the View menu or clicking the 

3D View button  in the Compute toolbar.

See also: ES3D Main Window; 3D Viewer.





5.24 Checking

The user can check the input data by selecting the Check option in the Compute menu or by clicking the Check 

button  in the Compute toolbar. 

If no error is detected, the OK message is displayed in a dialog box, as shown below. Click OK to continue.

If an error is detected, a message is shown in a dialog box, as shown in the example below. Click OK to continue.

The error messages are self-explanatory. To correct an error, modify the input data accordingly.

Error checking is automatically done before performing segmentation.

Error checking is also built into data input in dialog boxes. A dialog box cannot be closed if inappropriate data is 
entered.

See also: ES3D Main Window.



5.25 Segmenting

The input data must be segmented before numerical analysis is started. Segmentation consists of subdividing all 
conductor surfaces and dielectric-to-dielectric interfaces into small patches (subdomains). 

To improve the accuracy and efficacy of computations, a self-adaptive segmentation procedure is applied, where the 
surfaces are segmented nonuniformly. Patches are smaller toward edges and wedges of the analyzed structure.

The user can initiate segmentation by selecting the Segment option in the Compute menu or by clicking the Segment 

button  in the Compute toolbar. After segmentation is complete, a message is displayed informing the user 
about the total number of patches (unknowns), as shown below. Click OK to continue.

A segmented structure can be viewed using the 3D viewer.

Segmentation is executed automatically within the AutoRun sequence. In that case, no message is displayed.

The algorithm for segmentation has three parameters that can be modified by the user in the Settings dialog box. 
This dialog box can be opened by selecting the Settings option in the Project menu. The parameters are located on 
the Segmentation tab of this dialog box, as shown below.

The Resolution parameter influences the size of the smallest patch in the segmentation scheme. The patch size 
reduces as the Resolution parameter is increased. Consequently, the total number of unknowns (patches) increases. 
The recommended Resolution parameter is 1. It is not recommended to use values smaller than 1, as small details of 
the drawing can be missed in the segmentation.

The Refine parameter defines the rate at which the patch size diminishes going toward an edge or wedge of the 
analyzed structure. Increasing the Refine parameter increases the steepness of the patching scheme. The 
recommended Refine parameter is 1. 

The Number of VIA segments parameter defines the number of vertices of a regular polygon that is used to 
approximate a circular via. The recommended value is in the range of 4−6. The polygon is midway between a 



regular polygon that is inscribed into the via circle and a regular polygon that is circumscribed around the via circle.

See also: ES3D Main Window.



5.26 Computing

After all input data has been defined and checked, and after segmentation has been performed, ES3D is ready for 
the numerical analysis of the electrostatic system being considered. The numerical analysis is performed by running 
the program kernel (which is located in the dynamic-link library Capacit.dll). 

The kernel can be started from the ES3D main window in several ways:

• by selecting the Run option in the Compute menu;

• by clicking the Run button  in the Compute toolbar;

• by selecting the AutoRun option in the Compute menu;

• by clicking the AutoRun button  in the Compute toolbar.

The AutoRun option and the AutoRun button initiate a sequence of steps (which include saving, checking, and 
segmentation of input data, running the kernel, and listing output files), in which running the kernel is the main step.

The input data for the kernel consists of the segmented structure (described in the file with the name of the current 
project and extension lst) and data that defines the frequencies for tabulating the admittance parameters.

The kernel performs the following major steps:

• Rechecks the input data for consistency.

• Forms a system of linear equations based on the Method of Moments [1] (matrix fill-in). During this step, a 
dialog box is opened showing the progress of computations, as shown below.

The computations can be canceled by clicking the Cancel button. The CPU time for this step is 
proportional to the number of unknowns (patches) squared. 

• Solves the system of linear equations (using LU decomposition). During this step, a dialog box is opened, 
showing the progress of computations, as shown below.

The computations can be canceled by clicking the Cancel button. The CPU time for this step is 
proportional to the number of unknowns (patches) cubed. If the available RAM is insufficient to store the 
complete system of linear equations, swapping to the hard disk is used automatically, which slows down 



the computations.

• Calculates the matrices of electrostatic-induction coefficients and partial capacitances and tabulates the 
admittance (y) parameters.

See also: Analysis Cycle; Stand-Alone Solver.



5.27 Listing Results

The results of the analysis are written to three output-data files. The first file contains electrostatic-induction 
coefficients and partial capacitances for the case in which all conductors are assumed to be hot. The second file 
contains the equivalent network of partial capacitances for the case in which Conductor 0 is grounded. The third file 
contains tabulated admittance (y) parameters. 

These files can be opened individually by selecting the corresponding option in the List menu.

In the Output tab of the Settings dialog box one can select the default files that are displayed as the output. At least 
one file must be selected. The default files are displayed upon clicking the List Results button in the Compute 
toolbar. The default files are also automatically displayed at the end of the AutoRun sequence.

See also: ES3D Main Window.



5.28 Project Files

Each project includes several files. One file contains the input data, three files contain the output data, one file is 
auxiliary, and one file contains the DXF export. All of these files have the same name as the project name, and all 
reside in the same directory as the input-data file. Several temporary files are also created, but they are not 
documented in this manual.

The files are listed below. N is the largest conductor index of the analyzed structure. 

• Input-data file, with the default extension e3d.

• Output-data file containing the electrostatic-induction coefficients and partial capacitances for the case in 
which all N+1 conductors are treated as hot. The default extension is dat.

• Output-data file containing the equivalent network of partial capacitances for the case in which Conductor 
0 is assumed to be grounded. The default extension is ckt.

• Output-data file containing the admittance parameters of the equivalent network, tabulated as a function of 
frequency. The default extension has the form y0p, y1p, y2p, ..., y9p, y10, y11, ..., where the numbers 
represent N in decimal notation.

• Auxiliary file containing the output data of the segmentation, with the default extension lst. The lst file is 
used as the input to the program for 3D viewing and for the kernel DLL for numerical analysis.

• Export file in the DXF format, with the default name extension dxf.

The input-data file is present upon creating the project and saving it for the first time. It is automatically updated in 
the AutoRun sequence. It has to be updated by the user before manually initiating the Segmentation or Checking 
procedures. 

The three output-data files are created whenever the Run procedure is activated, but they contain no valid data if the 
Run procedure is interrupted. 

The lst file is created whenever the Segmentation procedure is completed. 

The dxf file is created only upon user's request to export the input data.



5.29 Input File

All input data that defines a project is stored in the input-data file, which has the default extension e3d. The 
filename is the same as the project name. The input-data file can be stored anywhere on the computer. All other files 
related to the project are stored in the same directory as the input-data file. All files have the same name as the 
project.

The input-data file is a binary file. A description of the file structure follows. 

The assumed numbers of bytes for variables are:

• double=8 bytes,

• float=4 bytes,

• int=4 bytes,

• word=2 bytes,

• byte=1 byte,

• char=1 byte,

• string=as many bytes as the number of characters.

The variables are ordered as follows (metalanguage description):

• string ES3D (4 bytes, without the terminating NULL character),

• byte FileVersion,

• byte FileSubVersion,

• word FileRevision,

• double MagnificationFactorfactor to convert from the internal unit for coordinates, which is 10 µ
m, to millimeters (0.01),

• double FrequencyStartstart frequency for tabulating admittance parameters (in the selected unit),

• double FrequencyStopstop frequency for tabulating admittance parameters (in the selected unit),

• int nFrequencynumber of frequency steps,

• int FrequencyUnitsunit for fStart and fStop (1e3, 1e6, or 1e9 Hz),

• double Resolutionresolution parameter for segmentation,

• double Refinerefine parameter for segmentation,

• int Unitsunit for coordinates, selected by the user (0=mm, 1=m, 2=inch, 3=mil),



• double GridSpacinggrid spacing (unit: 10 µm),

• int NumViaSegmentsnumber of segments for vias,

• double FootprintLengthlength of the footprint (unit: 10 µm),

• double FootprintWidthlength of the footprint (unit: 10 µm),

• byte MetalNorthindicator of whether the vertical surface of the dielectric for y=FootprintWidth is 
metallized (0=false, 1=true),

• byte MetalWestindicator of whether the vertical surface of the dielectric for x=0 is metallized (0=
false, 1=true),

• byte MetalSouthindicator of whether the vertical surface of the dielectric for y=0 is metallized (0=
false, 1=true),

• byte MetalEastindicator of whether the vertical surface of the dielectric for x=FootprintLength is 
metallized (0=false, 1=true),

• int NumberOfLayersnumber of metallization layers (at least 1),

• for (int i=0; i<NumberOfLayers; i++)data for layers and polygons (conductors):

o double Errelative permittivity, 

o double Zz-coordinate of the layer surface (unit: 10 µm),

o char LayerColor[4]RGB values for the layer color (0−255); the last byte is empty,

o byte Lockedindicator of whether the layer is locked (0=false, 1=true),

o byte Visibleindicator of whether the layer is visible (0=false, 1=true),

o char LayerName[51]layer name, maximum 50 characters, terminated by the NULL character,

o int NumberOfPolygonsnumber of polygons in the layer,

o for(int j=0; j<NumberOfPolygons; j++)data for polygons:

• int Indexindex of the conductor to which the polygon belongs (Conductor 0, 
Conductor 1,...),

• int PolygonIDpolygon ID (as displayed in the Project bar),

• byte Closedindicator if the polyline is closed (0=false, 1=true),

• int NumberOfNodesnumber of polygon nodes,

• for (int k=0; k<NumberOfNodes; k++)data for nodes:

•  µ



• double xx-coordinate of the node (unit: 10 µm),

• double yy-coordinate of the node (unit: 10 µm),

• double zz-coordinate of the node (unit: 10 µm); it must be equal to the z
-coordinate of the layer surface,

• int NumberOfViasnumber of vias,

• for(int i=0; i<NumberOfVias; i++)data for vias:

o int ViaIDvia ID (VIA 0, VIA 1...),

o double rvia radius (unit: 10 µm),

o double xx-coordinate of the via center (unit: 10 µm),

o double yy-coordinate of the via center (unit: 10 µm),

o double TopLayerz-coordinate of the via top surface (unit: 10 µm); it must be equal to the z
-coordinate of a layer surface,

o double BottomLayerz-coordinate of the via bottom surface (unit: 10 µm); it must be equal to 
the z-coordinate of a layer surface,

o byte Solidindicator if the via is solid (0=false=hollow, 1=true=solid),

• int NextLayerIDnext available layer ID (for the default layer name Layer 0, Layer 1...),

• int NextPolygonIDnext available polygon ID,

• int NextViaIDnext available layer via ID.



5.30 Output Files

The results of ES3D are the electrostatic-induction coefficients, the partial capacitances, and the admittance matrix. 
One set of results corresponds to the case in which all conductors are hot (including Conductor 0). The other set of 
results corresponds to the case in which Conductor 0 is assumed to be grounded. The highest index of a conductor is 
N.

The results of the analysis are written to three output-data files. All of these files have the same name as the project. 
The output files are saved in the same directory as the project file (which contans the input data). All output files are 
ASCII files. ES3D displays them using Notepad.

The output-data files are as follows:

• The file with the default extension dat contains the matrix [BN+1] of electrostatic-induction coefficients and 
the corresponding matrix [C] of partial capacitances. Conductor 0 is treated as a hot conductor, and the 
reference point (zero-potential point) is at infinity. 

An example of the dat file is shown below (0805pads.dat).

Wed Aug 09 18:18:58 2006

Calculations [s]:

Matrix filling   1

Matrix inversion 0

Total time       1

Total number of unknowns 306

B matrix [F]

    5.24784e-013   -1.46662e-013   -1.47168e-013

   -1.42821e-013    1.84015e-013    -2.0332e-014

   -1.42845e-013   -2.03263e-014    1.84047e-013

C matrix [F]

    2.30955e-013    1.46662e-013    1.47168e-013

    1.42821e-013    2.08622e-014     2.0332e-014

    1.42845e-013    2.03263e-014    2.08756e-014

The first row and column in each matrix correspond to Conductor 0, the second row and column 
correspond to Conductor 1, and so on. The output also contains the date and time when the analysis ended, 
as well as the duration of computations.

These results are displayed upon clicking the List Results button in the Compute toolbar (provided the dat 
file is checked as the default output) or upon selecting the C Parameters option in the List menu. The file is 
automatically displayed at the end of the AutoRun sequence (provided the dat file is checked as the default 
output).

• The file with the default extension ckt contains a description of the network formed by the partial 
capacitances. The description is in Touchstone®-compatible format. 

An example of the ckt file is shown below (0805pads.ckt).



CAP 1 0 c= 1.636834e-001

CAP 1 2 c= 2.032912e-002

CAP 2 0 c= 1.637206e-001

The potential of Conductor 0 is assumed zero (i.e., this conductor is shorted to the reference point at 
infinity). Conductor 0 corresponds to node 0, Conductor 1 corresponds to node 1, and so on. The 
capacitances are in pF. This file is empty if N=0.

These results are displayed upon clicking the List Results button in the Compute toolbar (provided the ckt 
file is checked as the default output) or upon selecting the Ckt option in the List menu. The file is 
automatically displayed at the end of the AutoRun sequence (provided the ckt file is checked as the default 
output).

• The file with the default extension of the form y0p, y1p, y2p, ..., y9p, y10, y11, ..., where the numbers 
represent N in decimal notation, contains tabulated y-parameters (admittance parameters) of the network 
formed by the partial capacitances from the ckt file. The file is in the Touchstone®-compatible format.

An example of the y-parameter file is shown below (0805pads.y2p).

# MHZ Y RI R 1

0.00000e+000    0       0.000000e+000    0       0.000000e+000

                0       0.000000e+000    0       0.000000e+000

1.00000e+000    0       1.156203e-006    0      -1.277496e-007

                0      -1.277137e-007    0       1.156401e-006

The first line is the standard header: the frequency is in MHz (this unit was selected in the Settings dialog 
box), the format is the real and imaginary part, and the admittance parameters are in siemens (S) because 
the reference resistance is 1Ω. The header is followed by a block for each frequency. The first number 
(hanging left) is the frequency. The remaining numbers in the block are the admittance parameters. The 
admittance parameters are purely imaginary, as the network is lossless. If N=0, no admittance parameters 
appear in this file.

These results are displayed upon clicking the List Results button in the Compute toolbar (provided the y
-parameter file is checked as the default output) or upon selecting the Y Parameters option in the List 
menu. The file is automatically displayed at the end of the AutoRun sequence (provided the y-parameter 
file is checked as the default output).



5.31 Segmentation File

The output of the segmentation procedure is written to an auxiliary file with the default extension lst. The file is an 
ASCII file. The lst file is used as the input to the 3D viewer program and for the kernel DLL for numerical analysis. 
This lst file is also used as the input file for the stand-alone execution of the ES3D kernel and stand-alone execution 
of the 3D viewer.

An example of the lst file is shown below for the case when N=2 (0805pads.lst). Only the first few lines of the file 
are displayed.

3

67

12

12

215

4

               0               0               0

            8.89               0               0

            8.89           19.05               0

               0           19.05               0

             4.6               1

4

           77.47               0               0

           77.47           19.05               0

            8.89           19.05               0

            8.89               0               0

             4.6               1

The first entry is the total number of conductors (N+1). The second entry is the number of patches for the first 
conductor (Conductor 0). The third entry is the number of patches for the next conductor (Conductor 1), and so on. 
There is a total of (N+1) such entries. The next entry is the number of patches for dielectric-to-dielectric interfaces.

These entries are followed by the data for patches. The first entry for a patch is the number of nodes (points, 
vertices). For each node, the Cartesian coordinates (x,y,z) are given. The unit for the coordinates is 0.01 mm=10 µ
m. The final two entries for a patch are the relative permittivity of the medium that is on the positive face of the 
patch and the relative permittivity of the medium that is on the negative face of the patch. The positive face is 
defined by the right-hand rule, with respect to the orientation of the patch contour. The orientation of the contour is 
defined by the order of nodes, as given in the above data.

See also: Capacitances.



5.32 Working with DXF Files

5.32.1 Importing DXF Files

The data for polylines and vias can be imported from AutoCAD® or a similar program that can handle the DXF 
(drawing interchange files) format. In such a program, a drawing should be created using the following rules:

• All coordinates (x,y) must be positive or zero. A drawing unit corresponds to one user's unit, which is 
defined in ES3D. 

• For drawing polygons, only 2D polylines that consist only of straight lines can be used. The information 
about the polyline width and elevation is not used.

• The default layer (“0”) is ignored.

• Define a layer named “FRAME”. This layer defines the footprint. Draw a rectangle in this layer, where one 
corner is at the coordinate origin (0,0), and the other corner defines the footprint. In other words, its 
coordinates are (Length,Width). Anything that is drawn must be within this rectangle.

• Create layers as in ES3D. Each layer should have a unique name.

• Within each layer, draw polylines as needed. Polylines drawn in a layer are later translated to polylines 
drawn in ES3D in the same layer. In other words, each polyline defines a metallization pattern.

• Vias are drawn in a layer named “VIA”. Each via is drawn as a circle, the center and radius of which 
correspond to the data for the via in ES3D.

• Save the data in a DXF file (AutoCAD® version 2000). The filename extension is dxf.

The DXF file is imported into ES3D using the Import option in the File menu. The name of the DXF file becomes 
the name of the project. When importing the DXF file, the user has to specify the following data:

• Unit for coordinates, so that one user's unit in ES3D corresponds to one drawing unit in the DXF file,

• Data for layers: relative permittivities and elevations (z-coordinates). One coordinate must be 0 (the lowest 
layer). All other coordinates must be positive. No two coordinates can coincide. For the layer whose 
elevation is z=0, the relative permittivity must be 1. The relative permittivities must be positive.

After the import is performed, all polygons are assigned to Conductor 0. For all vias, the top and bottom layers are 
set to the lowest layer. Hence, additional data should be supplied that describes the polygons and the vias:

• Select each polygon that does not belong to Conductor 0. Set the conductor index as appropriate.

• Select each via. Set the top layer and bottom layer as appropriate.

Before running the analysis, it may also be necessary to modify project settings (frequencies, segmentation data, and 
default outputs).

5.32.2 Exporting DXF Files

The data from the ES3D graphics editor can be exported to a DXF file (format compatible with AutoCAD® version 
2000) using the Export option in the File menu. In this export, polygons are converted to lines that are elevated to 
take into account the actual z-coordinate. Each via is converted to two circles located at the corresponding 



elevations and interconnected by vertical lines that represent the walls of the via. The default filename is the same as 
the project name. The filename extension is dxf. The exported file is not back compatible. In other words, it is not 
ready to be imported back into ES3D.

An example of the exported drawing is shown below (corresponding to LTCCAP.e3d). The colors correspond to the 
layer colors in ES3D.



5.33 Program Limits

ES3D has the following limits:

• maximal number of layers: 10;

• maximal number of conductors: 20;

• maximal number of polygons within a layer: 20;

• maximal number of polygon nodes: 50;

• maximal number of vias: 10;

• maximal number of via segments: 16;

• maximal number of patches (unknowns): 6000;

• maximal number of concurrently open projects: 10.



5.34 3D Viewer

A 3D view of a segmented structure is provided by selecting the 3D View option in the View menu of the ES3D 

main window or by clicking the 3D View button  in the Compute toolbar.

The structure is drawn in the ES3D View window, as shown below.

Patches that belong to dielectric-to-dielectric interfaces are green.

Colors of other patches correspond to the conductor indices. (In the Drawing window, the color of a polygon 
corresponds to the color of the layer in which the polygon resides.) Colors are ordered so that Conductor 0 is blue 
and the conductor with the largest index is red. In the above example (corresponding to the sample file 
0805pads.e3d), the total number of conductors is 3. Visible in the above example are Conductors 1 (violet) and 2 
(red). Conductor 0 is on the back face and is not visible unless the structure is rotated or clipped.

The displayed structure constitutes an object. Three Cartesian axes are attached to the object:

• Redparallel to the x-axis in the Drawing window,

• Greenparallel to the y-axis in the Drawing window,

• Blueparallel to the z-axis in the Drawing window.

The coordinate origin of the object displayed in the ES3D View window coincides with the centroid of the object. 
(In the Drawing window, the coordinate origin is in the lower-left corner of the lowest layer.)

The displayed object can be manipulated. It can be zoomed, panned (translated with respect to the window), rotated 
(with respect to the three axes attached to the object), and clipped (stripped by removing thin layers that are 
perpendicular to the blue axis).

The following menus are available in the ES3D View window:

• View menu resets, copies, and terminates the view:

o Resetresets the drawing to the initial state. Shortcut: Alt+R.

o Copycopies the drawing to the Clipboard. Shortcut: Ctrl+C.



o Exitcloses the ES3D View window. Shortcuts: Alt+F4 and Escape.

• Options menu controls the way the object is drawn:

o Axistoggles the axis display between on and off. Shortcut: Alt+A.

o WireFramedisplays polygon contours without fill. Shortcut: Alt+W.

An example is shown below.

o Filleddisplays filled polygons without contours. Shortcut: Alt+F.

An example is shown below.

o Bothdisplays filled polygons and contours. Shortcut: Alt+B.

An example is shown below.



• Clip menu controls clipping:

o NoClippingturns clipping off;

o ClipUpperremoves everything in the half-space above the clipping plane;

o ClipLowerremoves everything in the half-space below the clipping plane;

The shortcut for toggling among these three options is the End key. The position of the clipping plane is 
shifted up or down using the Insert and Delete keys, respectively. An example is shown below in which the 
ClipUpper option is in effect.

• Helpopens a summary of menus, keys, and mouse functions. Shortcut: F1.

The following function keys are active in the ES3D View window:

• F1opens a summary of menus, keys, and mouse functions; same as the Help menu item;

• Escape, Alt+F4closes the ES3D View window; same as the Exit option in the View menu;

• F5, F6, F7rotates according to the right-hand rule about the three axes of the coordinate system attached 
to the object (red, green, and blue, respectively);

• Alt+F5, Alt+F6, Alt+F7rotates according to the left-hand rule about the three axes of the coordinate 
system attached to the object (red, green, and blue, respectively). The Shift key and the Control key can be 
used instead of the Alt key.

• F8toggles the axis display between on and off; same as the Axis option in the Options menu;

• UpArrow, DownArrow, LeftArrow, RightArrowpans (translate) the drawing horizontally and 
vertically;

• PageUp, PageDownzooms in and out;

• Homeresets the drawing to the initial state; same as the Reset option in the View menu;

• Endtoggles the clipping mode between on and off, and switches clipping the upper and lower 
half-spaces; same as circling through the three options in the Clip menu;

• Insert, Deletemoves z-coordinate of the clipping plane up or down (with respect to the coordinate 
system attached to the object).



The left mouse button and the mouse wheel perform the following functions:

• Left-click+dragpans the drawing using the Hand cursor; similar to the Arrow keys;

• Wheelzooms in and out; same as the PageUp and PageDown keys;

• Ctrl+Wheel, Shift+Wheel, Tab+Wheelrotates about the three axes of the coordinate system attached to 
the object (red, green, and blue, respectively); same as the F5, F6, F7, Alt+F5, Alt+F6, and Alt+F7 keys.

Only one instance of the 3D viewer can be open at a time. Close the ES3D View window before displaying a new 
structure.

To save or print the drawing, copy the drawing to the clipboard, paste it into a program such as Microsoft Paint® or 
Microsoft Word®, and save or print the drawing.

See also: ES3D Main Window.



5.35 Stand-Alone Solver

The ES3D kernel dynamic-link library (DLL) can be used on a stand-alone basis to offer more flexibility to the user. 
The input data to the kernel is the data for the segmented structure. However, the structure need not be layered 
(planar) as generated by the ES3D graphics input. The analyzed structure can consist of arbitrarily shaped conductor 
and dielectric bodies.

The input-data file has the same structure as the lst file. The restrictions regarding the maximal numbers of 
conductors, patches, and nodes are the same as for any other structure analyzed by ES3D. Additional restrictions are 
that each patch must be planar and convex. The plane containing the patch can be arbitrary (in other words, it need 
not be a coordinate plane).

The user is responsible for providing consistent input data. The user should provide closed patched surfaces for 
each dielectric and properly specify dielectric relative permittivities with respect to the patch orientation. No 
checking of the data consistency is performed in the kernel.

To run the kernel on a stand-alone basis, start the program ES3DKernel.exe from a command window or from 
another program (for example, by using the CreateProcess function). Supply the name of the input-data file as 
the command-line parameter. The name extension must be lst.

ES3DKernel.exe sends messages to the user only by writing them to the file Kernel.log. This file is located in the 
same directory as ES3DKernel.exe. No windows or dialog boxes are used. If the kernel has ended successfully, the 
message “Done” is written to the file Kernel.log. If an error occurs, an error message is written instead.

The output-data files are automatically created with the same name as the input-data file. All files are located in the 
same directory as the input-data file. The y-parameters are evaluated at only one frequency, 1 GHz. (If needed, the y
-parameters can easily be calculated for any other frequency, as they are linearly proportional to frequency.)

The 3D viewer program, ES3DView.exe, can also be run on a stand-alone basis. The input to the program is also an 
lst file. To run the viewer, start the program ES3DView.exe from a command window or from another program. 
Supply the name of the input-data file as the command-line parameter.

A sample file for an arbitrary structure (Sphere.lst) is provided in the subdirectory Examples. The file defines a 
metallic sphere with a radius of 10 mm, embedded into a dielectric sphere, with a radius of 20 mm. The relative 
permittivity of the dielectric is 5. The 3D view of the sphere is shown below, with the top part clipped.

The theoretical capacitance of the sphere is 1.854 pF. The capacitance computed by ES3D is 1.882 pF.



The stand-alone execution of the kernel enables the user to analyze more general structures than can be defined in 
the ES3D graphics editor. In addition, the user can merge the generation of the input data and the analysis by the 
ES3D kernel into an optimization procedure or a procedure for batch processing.

See also: Segmentation file; Computing; 3D Viewer.
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